Web lists-archives.com

Re: eb1a:2860 eMPIA em28xx device to usb1 ??? usb hub problem?




Devin Heitmueller wrote:
> On Tue, Feb 23, 2010 at 1:37 AM, Dean <red1@xxxxxxxxxxxxxxxx> wrote:
>> Hi,
>>
>> I have the KWorld DVB-T 305U, an em28xx device.  Only the video works for me under Linux, no audio.  In case anyone wants to see it, I have attached the full dmesg text, solely from this device.
>>
>> Cheers,
>> Dean
> 
> Hi Dean,
> 
> How are you testing the audio, and under what video standard are you
> trying to use the device (NTSC/PAL/SECAM)?
> 
> Devin
>

Devin

I am receiving NTSC TV signals.  I test with mplayer.  Example;

mplayer tv://9 -tv driver=v4l2:alsa:immediatemode=0:adevice=hw.Em28xxAudio,0:norm=ntsc:chanlist=us-cable -vf pp=ci

The above command works fine (both audio and video) with my Hauppauge HVR-850, but for the Kworld 305U I must change 'immediatemode=0' to 'immediatemode=1' otherwise the video frame rate is about 1/2 normal speed and about 1 minute later mplayer starts printing 'video buffer full - dropping frame'.

According to dmesg the Kworld 305U loads the same firmware as my Hauppauge HVR-850, and (during separate test sessions) installs the same ALSA device;

card 1: Em28xxAudio [Em28xx Audio], device 0: Em28xx Audio [Empia 28xx Capture]
  Subdevices: 0/1
  Subdevice #0: subdevice #0


Dean

--
video4linux-list mailing list
Unsubscribe mailto:video4linux-list-request@xxxxxxxxxx?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/video4linux-list