Web lists-archives.com

Re: [Spca50x-devs] 046d:08d9 - works with gspca-modules but not 2.6.27-rc3




Arthur Marsh wrote:
> Hi, I've previously reported success getting 04cd:08d9 to work:
> 

<snip>

> 
> This worked for 2.6.26 kernels as well, but 2.6.27-rc3's built-in 
> support gives me dirty green screens, and gspca-source does not build on 
> 2.6.27-rc* kernels.
> 
> Output on 2.6.27-rc3 with build-in support:
> 

I have a 04cd:08d9 over here and it works fine.

2.6.27-rc3 is a bit old. Try the latest v4l-dvb hg tree (all gspca changes 
there are scheduled to become part of 2.6.27 final):

hg clone http://linuxtv.org/hg/~jfrancois/gspca/
cd gspca
make menuconfig
make
sudo make install

The remove *all* video related modules (so including videodev !!)
and do:
modprobe gspca_zc3xx

Then it should work (works for me) also notice that the new gspca no longer 
does JPEG decompression in kernel space, so either you need to use a program 
which understands cams which do JPEG, or use libv4l:
http://people.atrpms.net/~hdegoede/libv4l-0.4.1.tar.gz

Instructions are in the docs, libv4l is currently being packaged for Debian.

Regards,

Hans

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Spca50x-devs mailing list
Spca50x-devs@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/spca50x-devs