Web lists-archives.com

Re: [Spca50x-devs] Fwd: ubuntu 7.10 in amd64




Nazareno wrote:
> chuleymar@losotro:~$ spcaview -f r32
>  Spcaview version: 1.1.7 date: 06:11:2006 (C) mxhaard@xxxxxxxx 
> <mailto:mxhaard@xxxxxxxx>
> Initializing SDL.
> SDL initialized.
> bpp 4 format 5
> Using video device /dev/video0.
> Initializing v4l.
> **************** PROBING CAMERA *********************
> Camera found: Z-star Vimicro zc0301p
> Bridge found: ZC301-2
> Bridge find ZC301-2 number 13
> StreamId: JPEG Camera
> quality 1 autoexpo 1 Timeframe 0 lightfreq 50
> Bridge find ZC301-2 number 13
> Available Resolutions width 640  heigth 480 native 
> Available Resolutions width 352  heigth 288 decoded 
> Available Resolutions width 320  heigth 240 native *
> Available Resolutions width 176  heigth 144 decoded 
> unable to probe size !!
> *****************************************************
>  grabbing method default MMAP asked
> VIDIOCGMBUF size 2457632  frames 2  offets[0]=0 offsets[1]=1228816
> VIDIOCGPICT
> brightnes=32768 hue=0 color=0 contrast=32768 whiteness=0
> depth=32 palette=4
> VIDIOCSPICT
> brightness=32768 hue=0 color=0 contrast=32768 whiteness=0
> depth=32 palette=5
> 
> 
> Used 9938ms for 126 images => 78ms/image 12fps.
> Quiting SDL.
> Decoded frames:126 Average decode time: 2.000000
> unmapping
> closing
> closed
> Destroy Picture thread ...
> Quiting....
> chuleymar@losotro:~$
> 
> chuleymar@losotro:~$ spcagui
> 
> SpcaGui version: 0.3.5 date: 18 September 2005
> video device /dev/video0
> Camera found: Z-star Vimicro zc0301p
> VIDIOCGPICT brightnes=32768 hue=0 color=0 contrast=32768 
> whiteness=0depth=24 palette=4
> Bridge found: ZC301-2
> Unable to find a StreamId !!
> StreamId: 6 Unknow Camera
> try palette 15 depth 12
> Available  palette 15
> try palette 3 depth 16
> Available  palette 3
> try palette 4 depth 24
> Available  palette 4
> try palette 5 depth 32
> Available  palette 5
> probe size in
> Available Resolutions width 640  heigth 480
> Available Resolutions width 384  heigth 288
> Available Resolutions width 352  heigth 288
> Available Resolutions width 320  heigth 240
> Available Resolutions width 192  heigth 144
> Available Resolutions width 176  heigth 144
>  grabbing method default MMAP asked
> VIDIOCGMBUF size 2457632  frames 2  offets[0]=0 offsets[1]=1228816
> VIDIOCGPICT brightnes=32768 hue=0 color=0 contrast=32768 
> whiteness=0depth=12 palette=15
> VIDIOCGPICT brightnes=32768 hue=0 color=0 contrast=32768 
> whiteness=0depth=12 palette=15
> VIDIOCGPICT brightnes=32768 hue=0 color=0 contrast=32768 
> whiteness=0depth=12 palette=15
> VIDIOCSPICT brightnes=32768 hue=0 color=0 contrast=32768 
> whiteness=0depth=12 palette=15
> ByeBye !!
> unmapping frame buffer
> freeing frame buffer
> close v4l
> chuleymar@losotro:~$
> and the pastebin when i start and stop the spcagui: http://pastebin 
> <http://pastebin.com/m5e1f54a0>*MailScanner hat einen möglichen 
> Täuschungsversuch durch "pastebin.com" festgestellt.* .com/m5e1f54a0 
> <http://pastebin.com/m5e1f54a0>
> 
> and when i unplug and plug the cam i see:
> 
> Dec 16 17:40:19 losotro kernel: [  644.547566] usb 1-1: USB disconnect, 
> address 4
> Dec 16 17:40:36 losotro kernel: [  661.323980] usb 1-1: new full speed 
> USB device using uhci_hcd and address 5
> Dec 16 17:40:36 losotro kernel: [  661.519991] usb 1-1: configuration #1 
> chosen from 1 choice
> Dec 16 17:40:36 losotro kernel: [  661.522957] usb 1-1: ZC0301[P] Image 
> Processor and Control Chip detected (vid/pid 0x0AC8:0x301B)
> Dec 16 17:40:36 losotro kernel: [  661.597787] usb 1-1: No supported 
> image sensor detected
> Dec 16 17:40:36 losotro kernel: [  661.597836] 
> /home/chuleymar/imagenes_y_cosas/gspcav1-20071214/gspca_core.c: USB 
> GSPCA camera found.(ZC3XX)
> Dec 16 17:40:36 losotro kernel: [  661.597842] 
> /home/chuleymar/imagenes_y_cosas/gspcav1-20071214/gspca_core.c: 
> [spca5xx_probe:4254] Camera type JPEG
> Dec 16 17:40:37 losotro kernel: [  662.269330] 
> /home/chuleymar/imagenes_y_cosas/gspcav1-20071214/Vimicro/zc3xx.h: 
> [zc3xx_config:544]  Sensor UNKNOW_0 force Tas5130
> Dec 16 17:40:37 losotro kernel: [  662.272473] 
> /home/chuleymar/imagenes_y_cosas/gspcav1-20071214/gspca_core.c: 
> [spca5xx_getcapability:1238] maxw 640 maxh 480 minw 176 minh 144
> 

It looks like gspca can not find the right sensor:
Dec 16 16:39:17 losotro kernel: [   51.866277] 
/home/chuleymar/imagenes_y_cosas/gspcav1-20071214/Vimicro/zc3xx.h: 
[zc3xx_config:544]  Sensor UNKNOW_0 force Tas5130

According to the .inf file from the Windoz driver it is either one of these:
HV7131B
PB0330
PAS106B

Can you find out which sensor is used in your cam?

Michel, do you have any tips or hints?

Thomas


-- 
http://www.kaiser-linux.li

-------------------------------------------------------------------------
SF.Net email is sponsored by:
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services
for just about anything Open Source.
http://ad.doubleclick.net/clk;164216239;13503038;w?http://sf.net/marketplace
_______________________________________________
Spca50x-devs mailing list
Spca50x-devs@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/spca50x-devs