Web lists-archives.com

[Spca50x-devs] kernel 2.6.18, driver compilation




Hi all,

My problem is following:

uname -r
2.6.18-8.1.8.el5

my camera is:

lsusb
Bus 001 Device 005: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 
WebCam - this message I see from
my PC with 2.6.18-8.1.8.el5 kernel.

from PC, where is kernel 2.6.9-55.0.2.EL.cern I see thi same camera as 
Vimicro Zc301P 0x303b. Here I using
spca5xx-2006051 driver and all is o.k.

But on PC 2.6.18-8.1.8.el5 I cannot use spca5xx driver due to compiler 
error:
spca5xx-20060501# make
Building SPCA5XX driver for 2.5/2.6 kernel.
Remember: you must have read/write access to your kernel source tree.
make -C /lib/modules/`uname -r`/build 
SUBDIRS=/root/video/spca5xx-20060501 CC=cc modules
make[1]: Entering directory `/usr/src/kernels/2.6.18-8.1.8.el5-i686'
CC [M] /root/video/spca5xx-20060501/drivers/usb/spca5xx.o
In file included from 
/root/video/spca5xx-20060501/drivers/usb/spca5xx.c:39:
include/linux/config.h:6:2: warning: #warning Including config.h is 
deprecated.
/root/video/spca5xx-20060501/drivers/usb/spca5xx.c: In function 
‘spca5xx_open’:
/root/video/spca5xx-20060501/drivers/usb/spca5xx.c:2392: error: implicit 
declaration of function ‘video_devdata’

======================================================================

Unfortunately driver gspcav1-20070508 does not see my camera...

Can you dvice which driver can be able for kernel 2.6.18-8.1.8.el5-i686?

Thank you very much in advance.

Best regards,
Dusan

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
_______________________________________________
Spca50x-devs mailing list
Spca50x-devs@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/spca50x-devs