Web lists-archives.com

Re: [Spca50x-devs] Spca50x-devs Digest, Vol 14, Issue 6




Hi Paul,

This problem will be due to
1.You have compiled your spca driver before compiling kernel or kernel path
set in Makefile is different from the kernel using in the board.

send dmesg

Manjunath.AM

-----Original Message-----
From: spca50x-devs-bounces@xxxxxxxxxxxxxxxxxxxxx
[mailto:spca50x-devs-bounces@xxxxxxxxxxxxxxxxxxxxx]On Behalf Of
spca50x-devs-request@xxxxxxxxxxxxxxxxxxxxx
Sent: Thursday, July 26, 2007 4:55 PM
To: spca50x-devs@xxxxxxxxxxxxxxxxxxxxx
Subject: Spca50x-devs Digest, Vol 14, Issue 6


Send Spca50x-devs mailing list submissions to
	spca50x-devs@xxxxxxxxxxxxxxxxxxxxx

To subscribe or unsubscribe via the World Wide Web, visit
	https://lists.sourceforge.net/lists/listinfo/spca50x-devs
or, via email, send a message with subject or body 'help' to
	spca50x-devs-request@xxxxxxxxxxxxxxxxxxxxx

You can reach the person managing the list at
	spca50x-devs-owner@xxxxxxxxxxxxxxxxxxxxx

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Spca50x-devs digest..."


Today's Topics:

   1. RHEL 4 install problem (Paul Celona)
   2. Re: is this normal picture quality on Labtec Webcam	Pro?
      (Michel Xhaard)
   3. logitech quickcam chat - Shutter time (Nikolaus Viertl)
   4. USB webcam driver is not working with 2.6.10 kernel
      (Manjunath A M)
   5. Re: USB webcam driver is not working with 2.6.10	kernel
      (Manjunath A M)


----------------------------------------------------------------------

Message: 1
Date: Tue, 17 Jul 2007 12:40:47 -0400
From: "Paul Celona" <pcelona@xxxxxxxxxxxxx>
Subject: [Spca50x-devs] RHEL 4 install problem
To: <spca50x-devs@xxxxxxxxxxxxxxxxxxxxx>
Message-ID:
	<9E8C2EE38A83804B8A7CD8F5C5D6BA911452F7@xxxxxxxxxxxxxxxxxxxxxx>
Content-Type: text/plain; charset="iso-8859-1"

I am having a problem installing the spca5xx driver. I have downloaded the
spca5xx-v411goodbye package from the web site. I am running RHEL v4 u2
(2.6.9 kernel). the package compiles fine. "make install" returns that
install is up to date. insmod spca5xx.o command returns ---

insmod: error inserting 'spca5xx.o': -1 Invalid module format

Has anyone seen this before?

Paul
-------------- next part --------------
An HTML attachment was scrubbed...

------------------------------

Message: 2
Date: Tue, 17 Jul 2007 21:40:54 +0200
From: Michel Xhaard <mxhaard@xxxxxxxx>
Subject: Re: [Spca50x-devs] is this normal picture quality on Labtec
	Webcam	Pro?
To: spca50x-devs@xxxxxxxxxxxxxxxxxxxxx, Miernik <public@xxxxxxxxxxxx>
Message-ID: <200707172140.54880.mxhaard@xxxxxxxx>
Content-Type: text/plain;  charset="iso-8859-1"

Le Mardi 17 Juillet 2007 18:00, Miernik a ?crit?:
> I don't know if the picture quality is always so bad with this webcam,
> or do I have wring settings, or something?
>
> http://miernik.name/var/tmp/labtec-webcam-pro-test-01.jpeg
>
> This was captured with 'spcaview -b -g -f -r32 -l -N 1' but more or less
> whatever options I use, the result is equally bad.  I don't want a
> high-resolution picture, I just want a decent quality 640x480 picture.
> Take a look at the yellow wall in the upper-right corner. In reality it
> is a perfectly painted clean yellow wall, on this picture it looks like
> a dirty wall with stains all over the place. This is indoors at daytime.
> I manipulated the light conditions, and spcaview settings, and camera
> focus, and this is the best I could get. What the heck is wrong? Are
> these cameras really so crap, or can you get a better 640x480 picture
> with the right software and settings? If not, then what inexpensive
> webcam will give me a decent quality low resolution picture without
> spending a fortune? BTW: This was made with the use of a tripod.
>
> On http://article.gmane.org/gmane.linux.drivers.spca50x.devel/1548 there
> is a picture from the very same model of webcam, and the quality is much
> better, the wall of the house is really clean yellow, and clouds look
> like coulds, and not like toilet paper.
>
> Here is how this was captured:
>
> miernik@tarnica:~$ spcaview -b -g -f r32 -l -N 1
>  Spcaview version: 1.1.5 date: 12:12:2005 (C) mxhaard@xxxxxxxx
> Initializing SDL.
> SDL initialized.
> bpp 4 format 5
> Using video device /dev/video0.
> Initializing v4l.
> **************** PROBING CAMERA *********************
> Camera found: Labtec Webcam Pro
> Bridge found: ZC301-2
> Bridge find ZC301-2 number 13
> StreamId: JPEG Camera
> wrong spca5xx device
> Bridge find ZC301-2 number 13
> Available Resolutions width 640  heigth 480 native *
> Available Resolutions width 352  heigth 288 decoded
> Available Resolutions width 320  heigth 240 native
> Available Resolutions width 176  heigth 144 decoded
> *****************************************************
>  grabbing method READ asked
> VIDIOCGWIN height 480  width 640
> VIDIOCGPICT
> brightnes=32768 hue=0 color=0 contrast=32768 whiteness=0
> depth=24 palette=4
> VIDIOCSPICT
> brightness=32768 hue=0 color=0 contrast=32768 whiteness=0
> depth=32 palette=5
>
> VIDIOCSPICT newbright:34018
> brightness=34018 hue=0 color=0 contrast=32768 whiteness=0
> depth=32 palette=5
> VIDIOCSPICT newbright:35268
> brightness=35268 hue=0 color=0 contrast=32768 whiteness=0
> depth=32 palette=5
> VIDIOCSPICT newbright:36518
> brightness=36518 hue=0 color=0 contrast=32768 whiteness=0
> depth=32 palette=5
>  picture rgb32 07:17:2007-17:58:39-P0000.jpg
> VIDIOCSPICT newbright:37718
> brightness=37718 hue=0 color=0 contrast=32768 whiteness=0
> depth=32 palette=5
>
> Used 1171ms for 14 images => 83ms/image 11fps.
> Quiting SDL.
> Decoded frames:14 Average decode time: 25.000000
> closing
> closed
> Destroy Picture thread ...
> Quiting....
> miernik@tarnica:~$
try
spcaview -f jpg -l
Don't adjust brightness contrast and so on
To take the picture press the s key when you have the focus on the grabing
windows
regards
--
Michel Xhaard
http://mxhaard.free.fr



------------------------------

Message: 3
Date: Wed, 25 Jul 2007 08:49:06 +0200
From: "Nikolaus Viertl" <viertl@xxxxxxxxx>
Subject: [Spca50x-devs] logitech quickcam chat - Shutter time
To: spca50x-devs@xxxxxxxxxxxxxxxxxxxxx
Message-ID:
	<2d4551090707242349s884642ay481ee45d90de2964@xxxxxxxxxxxxxx>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Hi there,

I'm using ubuntu (7.04) with kernel 2.6.20.
A Logitech Quickcam Chat (046d:092c) is running with the gspca module.
In Camorama im getting the stream

My question: Is there a way to set the shutter speed?

I can set the contrast(gain) and brightness(offset), but not the shutter
speed.

Thanks in advance!

N.



------------------------------

Message: 4
Date: Thu, 26 Jul 2007 16:50:25 +0530
From: Manjunath A M <manjunatham@xxxxxxxxxxxxxxx>
Subject: [Spca50x-devs] USB webcam driver is not working with 2.6.10
	kernel
To: <davinci-linux-open-source@xxxxxxxxxxxxxxxxxxxx>,
	<linux-omap-open-source-owner@xxxxxxxxxxxxxxxxxxxx>,	"'Michel Xhaard'"
	<mxhaard@xxxxxxxx>, <spca50x-devs@xxxxxxxxxxxxxxxxxxxxx>
Cc: Yogesh Kumar M <yogeshkumarm@xxxxxxxxxxxxxxx>,	'Meher'
	<mail2meher@xxxxxxxxx>,	Mahendra Nayak M <mahendra@xxxxxxxxxxxxxxx>,
	Madhusudhan Srinivasan <madhusudhan@xxxxxxxxxxxxxxx>
Message-ID: <008001c7cf76$f72e5d90$9129320a@xxxxxxxxxx>
Content-Type: text/plain;	charset="iso-8859-1"

Hi all

I could able to make my webcam(logitech quick cam) work with TI-DAVINCI EMV
using
gspcav1-20070508 and spcaview-20061208 with 2.6.20-omap1 kernel.

But we need to use 2.6.10 for the board as per our client requirement. I am
facing strange problem with 2.6.10 usb driver, the details are as below:

Webcam will detect without any problem and when i run an application
./spcaview, it fails by returning usb_submit_urb(0) ret -16 (EBUSY).

I had put printk's in musb driver and found that EBUSY is because (in
musb_host.c, pEnd=musb_find_ep(pThis,pUrb);) pEnd is always = 0 or less,no
Isoc ep is allocated to webcam.

Is it because ep0 (for enumeration) is not released by webcam??.

some more inputs are

It uses fifo_mode=1 and address 2 for which only FIFO_RX is defined (in
drivers/usb/musb/plat_uds.c)where as in kernel 2.6.20 it uses fifo_mode=2
and address 3 for which only FIFO_RXTX is defined and hence no issues.

If i change the fifo_mode to 2 in kernel 2.6.10, inserting musb_hdrc.ko will
fail returning error -22.


I have attached dmesg for further information,

Note: If i use (spca5xx-20060501)spca5xx.ko driver,the webcam itself will
not be detected.
	In spca5xx-20060501 README file the kernel 2.6.10 is not listed, is it not
supported or not tested?

 Please suggest me how to approach to solve this problem..

 Thanks in advance
 Manjunath AM




------------------------------

Message: 5
Date: Thu, 26 Jul 2007 16:55:55 +0530
From: Manjunath A M <manjunatham@xxxxxxxxxxxxxxx>
Subject: Re: [Spca50x-devs] USB webcam driver is not working with
	2.6.10	kernel
To: "'manjunatham'" <manjunatham@xxxxxxxxxxxxxxx>,
	<davinci-linux-open-source@xxxxxxxxxxxxxxxxxxxx>,
	<linux-omap-open-source-owner@xxxxxxxxxxxxxxxxxxxx>,	"'Michel Xhaard'"
	<mxhaard@xxxxxxxx>, <spca50x-devs@xxxxxxxxxxxxxxxxxxxxx>
Cc: Yogesh Kumar M <yogeshkumarm@xxxxxxxxxxxxxxx>,	'Meher'
	<mail2meher@xxxxxxxxx>,	Mahendra Nayak M <mahendra@xxxxxxxxxxxxxxx>,
	Madhusudhan Srinivasan <madhusudhan@xxxxxxxxxxxxxxx>
Message-ID: <008101c7cf77$bc046150$9129320a@xxxxxxxxxx>
Content-Type: text/plain; charset="iso-8859-1"

Sorry, i forgot to attach dmesg,

Please find the attached dmesg.txt



 -----Original Message-----
From: 	manjunatham [mailto:manjunatham@xxxxxxxxxxxxxxx]
Sent:	Thursday, July 26, 2007 4:50 PM
To:	'davinci-linux-open-source@xxxxxxxxxxxxxxxxxx [manjunatham]   om';
'linux-omap-open-source-owner@xxxxxxxxxxxxxxxxxxxx'; 'Michel Xhaard';
'spca50x-devs@xxxxxxxxxxxxxxxxxxxxx'
Cc:	Mahendra Nayak M; Madhusudhan Srinivasan; 'Meher'; Yogesh Kumar M
Subject:	USB webcam driver is not working with  2.6.10 kernel

Hi all

I could able to make my webcam(logitech quick cam) work with TI-DAVINCI EMV
using
gspcav1-20070508 and spcaview-20061208 with 2.6.20-omap1 kernel.

But we need to use 2.6.10 for the board as per our client requirement. I am
facing strange problem with 2.6.10 usb driver, the details are as below:

Webcam will detect without any problem and when i run an application
./spcaview, it fails by returning usb_submit_urb(0) ret -16 (EBUSY).

I had put printk's in musb driver and found that EBUSY is because (in
musb_host.c, pEnd=musb_find_ep(pThis,pUrb);) pEnd is always = 0 or less,no
Isoc ep is allocated to webcam.

Is it because ep0 (for enumeration) is not released by webcam??.

some more inputs are

It uses fifo_mode=1 and address 2 for which only FIFO_RX is defined (in
drivers/usb/musb/plat_uds.c)where as in kernel 2.6.20 it uses fifo_mode=2
and address 3 for which only FIFO_RXTX is defined and hence no issues.

If i change the fifo_mode to 2 in kernel 2.6.10, inserting musb_hdrc.ko will
fail returning error -22.


I have attached dmesg for further information,

Note: If i use (spca5xx-20060501)spca5xx.ko driver,the webcam itself will
not be detected.
	In spca5xx-20060501 README file the kernel 2.6.10 is not listed, is it not
supported or not tested?

 Please suggest me how to approach to solve this problem..

 Thanks in advance
 Manjunath AM
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: dmesg.txt

------------------------------

-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/

------------------------------

_______________________________________________
Spca50x-devs mailing list
Spca50x-devs@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/spca50x-devs


End of Spca50x-devs Digest, Vol 14, Issue 6
*******************************************


-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
_______________________________________________
Spca50x-devs mailing list
Spca50x-devs@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/spca50x-devs