Web lists-archives.com

Re: [Spca50x-devs] Problems with a labtec webcam pro




> Dear all,
> 
> I own a webcam Labtec Webcam Notebook.
> 
> I use an USB 2.0 minihub connected to a USB 2.0 PCMCIA card, but, the traces
> are different if I connect directly to the PCMCIA-hub or to the USB
> 2.0minihub. See below (I'm using kernel
> 2.6.21 and gspcav1-20070508).
> 
> Later, when i use spcaview it does it right in case of direct connection but
> not with connection via the USB2.0 minihub.
> 
> What's the problem?
> Thanks,
> David
> 
> 
> ---- dmesg for direct connection to USB 2.0 PCMCIA card ----
> usb 3-2: new full speed USB device using ohci_hcd and address 4
> usb 3-2: configuration #1 chosen from 1 choice
> /home/david/descargas/webcam/gspcav1-20070508/gspca_core.c: USB GSPCA camera
> found.(ZC3XX)
> /home/david/descargas/webcam/gspcav1-20070508/gspca_core.c:
> [spca5xx_probe:4098] Camera type JPEG
> /home/david/descargas/webcam/gspcav1-20070508/Vimicro/zc3xx.h:
> [zc3xx_config:515] Sensor ID:9
> /home/david/descargas/webcam/gspcav1-20070508/Vimicro/zc3xx.h:
> [zc3xx_config:582] Find Sensor PAS202BCB
> /home/david/descargas/webcam/gspcav1-20070508/gspca_core.c:
> [spca5xx_getcapability:1215] maxw 640 maxh 480 minw 176 minh 144
> usbcore: registered new interface driver gspca
> /home/david/descargas/webcam/gspcav1-20070508/gspca_core.c: gspca driver
> 01.00.18 registered
> 
> ---- dmesg for connection to USB2.0 minihub connected to a USB 2.0 PCMCIA
> card ----
> usb 4-1.1: new full speed USB device using ehci_hcd and address 80
> usb 4-1.1: configuration #1 chosen from 1 choice
> /home/david/descargas/webcam/gspcav1-20070508/gspca_core.c: USB GSPCA camera
> found.(ZC3XX)
> /home/david/descargas/webcam/gspcav1-20070508/gspca_core.c:
> [spca5xx_probe:4098] Camera type JPEG
> /home/david/descargas/webcam/gspcav1-20070508/Vimicro/zc3xx.h:
> [zc3xx_config:515] Sensor ID:9
> /home/david/descargas/webcam/gspcav1-20070508/Vimicro/zc3xx.h:
> [zc3xx_config:525] Find Sensor UNKNOW_0 force Tas5130
> /home/david/descargas/webcam/gspcav1-20070508/gspca_core.c:
> [spca5xx_getcapability:1215] maxw 640 maxh 480 minw 176 minh 144
> 
It is know issue.  It is the problem of USB subsystem. In this case I would recommend to use direct connection
to USB controller (preferably) or try my force_issign_sensor_ID patch http://mgspca.e1.bmstu.ru/gspcav1-20070110-add-force_id_sensor_assign.diff.bz2
In your case patched gspca driver should be loaded by next command:

modprobe gspca force_sensor_id=9

Your webcam is USB ID base detected and initially the type of a sensor has been detected correctly, 

 [zc3xx_config:515] Sensor ID:9

however in this case the subsequent procedure of auto detection of type of a sensor (which it is not actual for your webcam) has given failure.

-- 
Regards,
Serge A. Suchkov
--
If this is timesharing, give me my share right now.

-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
_______________________________________________
Spca50x-devs mailing list
Spca50x-devs@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/spca50x-devs