Web lists-archives.com

[Spca50x-devs] Hints and Help for a Webcam ... [Skintek Snakecam 093a:260f ]




Hello world ;-),
maybe somebody can help me directly, or maybe point me to the right direction ...

I've recently bought a "Skintek Snakecam" Webcam, and being a linux fan, I've
immediately tried to make it run under my favourite OS.
After connecting the camera, it claims itself as:

 Device 004: ID 093a:260f Pixart Imaging, Inc.

I see that this device is still not supported by spcaxx/gspca, but, being a
Pixart chip (from what I've understood, from the 93a id, it should probably
be a Pac207 ), in principle it would not be too hard to have it running under
linux ...
Being a very low skill hacker, I tried to fool my kernel by simply adding a
new entry in  the "gspca_core.c", namely by copy+paste+change a similar
entry ...
In more detail, i "cloned" every "QtecWb100" in the "enum" entry, in
the "struct cam_list" ... then I added an entry in the "static __devinitdata
struct usb_device_id device_table" adding (after the Qtec) a line as follows:

{USB_DEVICE(0x093a, 0x260f)},   /* Skintek Snakecam */

Obviously I added a proper entry also in the "case 0x93a" of the  
spcaDetectCamera, i.e.:

                case 0x260f:
                        spca50x->desc = SkintekSnakecam;
                        spca50x->bridge = BRIDGE_PAC207;
                        spca50x->sensor = SENSOR_PAC207;
                        break;

The driver compiles and installs fine, and (obviously!) recognizes the camera
when inserted ...

usb 1-2: new device found, idVendor=093a, idProduct=260f
usb 1-2: new device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2: Product: VGA Single Chip
usb 1-2: Manufacturer: Pixart Imaging Inc.

and, after that, /var/log/messages continues with

gspca_core.c: USB SPCA5XX camera found. (PAC207)
gspca_core.c: [spca5xx_probe:3895] Camera type GBRG
gspca_core.c: [spca5xx_getcapability:1167] maxw 352 maxh 288 minw 160 minh 120
gspca_core.c: [spca5xx_open:1906] DEALLOC error on spca50x_init_source
gspca_core.c: [spca5xx_open:1906] DEALLOC error on spca50x_init_source

and so on ... after that I disconnected the thing ... ;-(

So, all my "science" and "black magic" stops here ... any help would be
appreciated ... I'll be very happy of testing and trying any additional hint
and patch that someone can provide ...
Thanks in advance, and best regards ...
GP aka fiamazo

PS: additionally, I've done a couple of USB sniffs, both connecting only the device and  acquiring images ... under WinXP ... I can try to post them or host them somwhere, if needed ...
Thanks again ...
-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys - and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Spca50x-devs mailing list
Spca50x-devs@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/spca50x-devs