Web lists-archives.com

Re: [Samba] Problem joining domain [SEC=UNCLASSIFIED]




On Fri, 2019-05-31 at 06:21 +0000, Thamm, Russell via samba wrote:
> UNCLASSIFIED
> 
> Hi Andrew and Roland,
> 
> I originally installed samba-4.1.7 on CentOS 6.5. I successfully joined the domain. I intended to take over from the 2003 server but because the domain was being heavily used, I delayed seizing the roles. 
> 
> Now I really, really want to replace the 2003 server. The network is currently not in use and I want to complete the job while I have an opportunity. If I have no other option, I will create a new domain, but I'd prefer to avoid having to create new user accounts.

How about trying this:

https://wiki.samba.org/index.php/Create_a_samba_lab-domain

If that works, then you may be able to try this:

https://wiki.samba.org/index.php/Back_up_and_Restoring_a_Samba_AD_DC

an online backup might work against windows, but I suspect you will
hit:

https://bugzilla.samba.org/show_bug.cgi?id=13917

If you can apply patches (difficult air-gapped I know), try the
backported one attached to the bug.

Restoring the backup won't allow the windows server to still operate
(they will fight), but might get you a way out. 

Anyway, I hope this is of some help.  Otherwise we need to try and work
out a bit more about why the windows DC is unhappy with our list of
NCs.

Andrew Bartlett
-- 
Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba



-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba