Web lists-archives.com

Re: [Samba] domain won't go online




your keytab setup looks wrong. 

Can you also explain why there are 2 netbios names in there,normally only one should be in there.


only the real resolving hostname (-s) should be in there.


if you follow this basic rules for your (internal) revolving.


hostname -f is the real hostname.

hostname -i is the real ip

hostname -d the dnsdomain

hostname -s the local aliasname (on the linux server). which is also the netbios name, but in caps.


set for these in the dns the A and PTR records. 


any other when you want to use, cname it to the real hostname.


set upn/spn you need for the alias (cname), and your Kerberos resolving works now correct and let samba maintain it on the real hostname through winbind.


now im not at my computer, cant type it all on my phone. 


running my debug script might show more in whats going on.

and it answers all rowlands asked things, it your on debian related os.


My vacation started today so im low on response..


Greetz,


Louis











Op 30 mei 2019, om 16:59, Rowland penny via samba <samba@xxxxxxxxxxxxxxx> schreef: 
On 30/05/2019 15:44, Brian J. Murrell via samba wrote:
Hi. I'm hoping for some advise/help.

I have a domain that won't seem to go online:

$ wbinfo --online-status
BUILTIN : active connection
MY-HOST : active connection
FOO : no active connection



I'm really not sure how to go about debugging why this is happening. I
don't have any admin access to the domain so my ability to debug is
client side only. But this was working before.

Any advise?

I really must buy a crystal ball LOL

What OS ?

What Samba version did it work with ?

What Samba version doesn't work

What is in the smb.conf file ?

Rowland




-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba