Web lists-archives.com

[Samba] Debian Stretch samba 4.10.4 amd/i386 available now. ! Manual step needed when upgrading !




Hai Guys, 

Upcoming: 
The Ubuntu Bionic packages are also coming soon, 
im adding i386 support thats why its taking a bit longer then normal. 

The following has been done: 
Debian Stretch samba 4.10 amd64/i386	Updated to samba 4.10.4

I bit later then normal, this was due to a small change needed in ldb
packages.
I needed to move one file to another package to allow a i386 build while
lmdb is enabled. 

Repo Info	: http://apt.van-belle.nl/ 
Buildlogs	: http://downloads.van-belle.nl/

Spotlight and the vfs_nfs4_xattr and lmdb support are included in these
builds. 

>>>  Do note, LMDB support is only enabled in the AMD64 builds.  <<< 

---  The quick install for the repo. --- 
1) Choose http or https for you apt, both work, for https you need to :
apt install apt-transport-https

2) Import my public key
wget -O - http://apt.van-belle.nl/louis-van-belle.gpg-key.asc | apt-key add
-

3) (optional) setup a header line for the repo file.
echo "# AptVanBelle repo for samba." | sudo tee
/etc/apt/sources.list.d/van-belle.list

4) In the line below, change the OS and/or samba version to what you want. 
Choose only one! 
Stretch 4.10 : echo "deb http://apt.van-belle.nl/debian stretch-samba410
main contrib non-free" | sudo tee -a /etc/apt/sources.list.d/van-belle.list

Upgrading from Jessie to Stretch, have a look here : 
http://downloads.van-belle.nl/samba4/Upgrade-info.txt


         Upgrade Side note.   

Only people who are upgradeing samba will notice this, new installs not. 
The change in the ldb will show and error while upgrading, due to the move
of one file to an other packages. 
Just run : apt --fix-broken install 
And its done, i've added an sample of the output, so you can see what
happens. 
Sorry, i could not figure out a better way. 
I tripple tested the upgrade on members and AD-DC's, its a one time job...

This is the output of the last my domain controller i upgraded. 

You will see the following output. 
Calculating upgrade... Done
The following packages will be upgraded:
  ldb-tools libldb1 libnss-winbind libpam-winbind libsmbclient libwbclient0
python3-ldb python3-samba samba samba-common samba-common-bin
samba-dsdb-modules samba-libs samba-vfs-modules smbclient winbind
16 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 12.6 MB of archives.
After this operation, 4,096 B of additional disk space will be used.
Do you want to continue? [Y/n]

Unpacking ldb-tools (2:1.5.4-1debian3) over (2:1.5.4-1debian2) ...
Errors were encountered while processing:
 /tmp/apt-dpkg-install-WWT3dY/01-libldb1_2%3a1.5.4-1debian3_amd64.deb
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)

apt --fix-broken install

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libldb1
The following packages will be upgraded:
  libldb1
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
15 not fully installed or removed.
Need to get 0 B/140 kB of archives.
After this operation, 52.2 kB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 40734 files and directories currently installed.)
Preparing to unpack .../libldb1_2%3a1.5.4-1debian3_amd64.deb ...
Unpacking libldb1:amd64 (2:1.5.4-1debian3) over (2:1.5.4-1debian2) ...
Setting up libwbclient0:amd64 (2:4.10.4+nmu-1debian1) ...
Setting up libldb1:amd64 (2:1.5.4-1debian3) ...
Setting up samba-common (2:4.10.4+nmu-1debian1) ...
Setting up python3-ldb (2:1.5.4-1debian3) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Processing triggers for systemd (232-25+deb9u11) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up ldb-tools (2:1.5.4-1debian3) ...
Setting up samba-libs:amd64 (2:4.10.4+nmu-1debian1) ...
Setting up samba-vfs-modules:amd64 (2:4.10.4+nmu-1debian1) ...
Setting up libsmbclient:amd64 (2:4.10.4+nmu-1debian1) ...
Setting up smbclient (2:4.10.4+nmu-1debian1) ...
Setting up python3-samba (2:4.10.4+nmu-1debian1) ...
Setting up samba-dsdb-modules:amd64 (2:4.10.4+nmu-1debian1) ...
Setting up samba-common-bin (2:4.10.4+nmu-1debian1) ...
Checking smb.conf with testparm
Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Server role: ROLE_ACTIVE_DIRECTORY_DC

Done
Checking smb.conf with samba-tool
INFO 2019-05-24 16:20:12,607 pid:42310
/usr/lib/python3/dist-packages/samba/netcmd/testparm.py #96: Loaded smb
config files from /etc/samba/smb.conf
INFO 2019-05-24 16:20:12,607 pid:42310
/usr/lib/python3/dist-packages/samba/netcmd/testparm.py #97: Loaded services
file OK.
Done
Setting up winbind (2:4.10.4+nmu-1debian1) ...
Samba is being run as an AD Domain Controller: Masking winbind.service
Please ignore the following error about deb-systemd-helper not finding those
services.
(winbind.service already masked)
Setting up libpam-winbind:amd64 (2:4.10.4+nmu-1debian1) ...
Setting up samba (2:4.10.4+nmu-1debian1) ...
Samba is being run as an AD Domain Controller: Masking smbd.service
nmbd.service
Please ignore the following error about deb-systemd-helper not finding those
services.
(smbd.service already masked)
(nmbd.service already masked)
Setting up libnss-winbind:amd64 (2:4.10.4+nmu-1debian1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Scanning processes...
Scanning candidates...
Scanning linux images...
Running kernel seems to be up-to-date.
Restarting services...
 systemctl restart bind9.service fam.service ntp.service postfix@-.service
snmpd.service ssh.service
Services being skipped:
 /etc/needrestart/restart.d/dbus.service
No containers need to be restarted.
User sessions running outdated binaries:
 root @ user manager service: systemd[40606]


Greetz, 

Louis


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba