Web lists-archives.com

Re: [Samba] samba does not honor set group bit on directories




On Wed, 8 May 2019 15:13:02 +0200
Peter Varkoly via samba <samba@xxxxxxxxxxxxxxx> wrote:

> Hi,
> 
> I'm using samba 4.6.15 and 4.8.9 as AD server on a lot of openLeap
> 42.3 server.
> 
> The server have numerous group directories in /home/groups. This 
> drirectory will be provided by a share:
> 
> [groups]
>          comment = Shared directories of groups you are member in.
>          path = /home/groups
>          inherit permissions = Yes
>          inherit acls = Yes
>          browseable = Yes
>          guest ok = No
>          printable = No
>          read only = No
> 
> On the group directories the set group ID bit is set:
> 
> # file: home/groups/WBFRH1.1
> # owner: root
> # group: <DOMAIN>\134wbfrh1.1
> # flags: -s-
> user::rwx
> group::rwx
> group:<DOMAIN>\134wbfrh1.1:rwx
> mask::rwx
> other::---
> default:user::rwx
> default:group::rwx
> default:group:<DOMAIN>\134wbfrh1.1:rwx
> default:mask::rwx
> default:other::---
> 
> Creating a file in /home/groups/WBFRH1.1 on the server the group is
> as expected WBFRH1.1.
> 
> Creating a file via smbclient or from Windows client the group of the 
> file is the primary group of the user.
> 
> Why is the behavior different?
> 
> How can I force that samba honors the linux settings?

Might help if you post the '[global]' part of your smb.conf

Rowland



-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba