Web lists-archives.com

Re: [Samba] 4.10.2 not connecting to (old) NAS




On Tue, 7 May 2019 18:06:35 -0400
Phil Dermott <pdermott@xxxxxxxxxx> wrote:

> As requested - smb.conf
> 
> # See smb.conf.example for a more detailed config file or
> # read the smb.conf manpage.
> # Run 'testparm' to verify the config is correct after
> # you modified it.
> 
> [global]
>  ?????????????? workgroup = HOME
>  ?????????????? server string = Samba Server Version %v
>  ?????????????? netbios name = LP
> 
> # log files split per-machine:
>  ?????????????? log file = /var/log/samba/log.%m
>  ?????????????? max log size = 50
> 
>  ?????????????? security = user
> 
>  ?????????????? passdb backend = tdbsam
> 
>  ?????????????? printing = cups
>  ?????????????? printcap name = cups
>  ?????????????? load printers = yes
>  ?????????????? cups options = raw
> 
> [homes]
>  ?????????????? comment = Home Directories
>  ?????????????? valid users = %S, %D%w%S
>  ?????????????? browseable = No
>  ?????????????? read only = No
>  ?????????????? inherit acls = Yes
> 
> [printers]
>  ?????????????? comment = All Printers
>  ?????????????? path = /var/tmp
>  ?????????????? printable = Yes
>  ?????????????? create mask = 0600
>  ?????????????? browseable = No
> 
> [print$]
>  ?????????????? comment = Printer Drivers
>  ?????????????? path = /var/lib/samba/drivers
>  ?????????????? write list = @printadmin root
>  ?????????????? force group = @printadmin
>  ?????????????? create mask = 0664
>  ?????????????? directory mask = 0775
> 
> [Elements]
>  ?????? path = /media/Elements
>  ?????? comment = Extra drive
>  ?????? browseable = yes
>  ?????? public = yes
>  ?????? writable = yes
> [Vuze]
>  ?????? path = /mnt/extradasd/Vuze
>  ?????? comment = Vuze storage
>  ?????? browseable = yes
>  ?????? public = yes
>  ?????? writable = yes
> [Extradasd]
>  ?????? path = /mnt/extradasd
>  ?????? comment = Additional storage
>  ?????? browseable = yes
>  ?????? public = yes
>  ?????? writable = yes
> 

Is the above from the NAS or the PCLOS computer ?
As it refers to printers, I think it is most likely from the PCLOS.

I think what is going on here is that your NAS is expecting NTLMv1 and
your new Samba 4.10.2 now has this turned off by default.

Try adding 'ntlm auth = yes' to the smb.conf

Rowland

PS What's with all the '?' marks

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba