Web lists-archives.com

Re: [Samba] Debian Stretch, Samba 4.10.2, 4.9.6 and 4.8.11 Available (amd64/i386)




Hi Louis,

Le 04/09/2019 à 08:51 AM, L.P.H. van Belle via samba a écrit :
ow ow .. slapping myself..  I forgot my note about the VERSION file..

That you see this : Version 4.10.2-Ubuntu
is because i use a Ubuntu as base for the 4.10 builds.
I'll correct that, but there is no difference in the packages once this is corrected back to Version 4.10.2-Debian.

It just a "version-name"

I've started doing some more testing on 4.10.2 using your packages. Thanks a lot for the good work!

Looking at the .dsc and tar.xz of the ldb package, LMDB support is explicitly disabled. Do you know if there is any reason for this?

Actually ldb package it is missing the dependency in ldb_1.5.4-1debian0.dsc and it is explicitly disabled in ldb_1.5.4-1debian0.debian/debian/rules (cf. diff below). It was properly configured in your packages in 4.9.

LMDB is the new db backend to provide for larger database (TDB is limited to 4GB of data). It is the default storage engine on OpenLDAP and can be enabled when provisioning or joining a domain using the --backend-store=mdb flag.

Cheers,

Denis

=============

diff -Naur ldb_1.5.4-1debian0.dsc ldb_1.5.4-1debian0.dsc.orig
--- ldb_1.5.4-1debian0.dsc	2019-04-30 14:13:09.134115370 +0200
+++ ldb_1.5.4-1debian0.dsc.orig	2019-04-30 14:12:41.062044477 +0200
@@ -9,7 +9,7 @@
 Standards-Version: 4.2.1
 Vcs-Browser: https://salsa.debian.org/samba-team/ldb
 Vcs-Git: https://salsa.debian.org/samba-team/ldb.git
-Build-Depends: debhelper (>= 11~), dh-exec, dh-python, docbook-xml, docbook-xsl, libcmocka-dev (>= 1.1.3~), libldap2-dev, liblmdb-dev (>= 0.9.18), libpopt-dev, libtalloc-dev (>= 2.1.16~), libtdb-dev (>= 1.3.18~), libtevent-dev (>= 0.9.39~), pkg-config, python (>= 2.7~), python-all-dev (>= 2.7~), python3 (>= 3.5~), python3-all-dbg (>= 3.5~), python3-all-dev (>= 3.5~), python3-talloc-dev (>= 2.1.16~), python3-tdb (>= 1.3.18~), xsltproc +Build-Depends: debhelper (>= 11~), dh-exec, dh-python, docbook-xml, docbook-xsl, libcmocka-dev (>= 1.1.3~), libldap2-dev, libpopt-dev, libtalloc-dev (>= 2.1.16~), libtdb-dev (>= 1.3.18~), libtevent-dev (>= 0.9.39~), pkg-config, python (>= 2.7~), python-all-dev (>= 2.7~), python3 (>= 3.5~), python3-all-dbg (>= 3.5~), python3-all-dev (>= 3.5~), python3-talloc-dev (>= 2.1.16~), python3-tdb (>= 1.3.18~), xsltproc
 Package-List:
  ldb-tools deb utils optional arch=any
  libldb-dev deb libdevel optional arch=any



diff -Naur ldb_1.5.4-1debian0.debian/debian/rules ldb_1.5.4-1debian0.debian.orig/debian/rules --- ldb_1.5.4-1debian0.debian/debian/rules 2019-04-30 14:16:42.286653941 +0200 +++ ldb_1.5.4-1debian0.debian.orig/debian/rules 2019-03-08 17:40:56.000000000 +0100
@@ -33,6 +33,7 @@
--minimum-library-version="$(shell ./debian/autodeps.py --minimum-library-version)" \
 		--libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
 		--with-modulesdir=/usr/lib/$(DEB_HOST_MULTIARCH)/ldb/modules \
+		--without-ldb-lmdb

 get-packaged-orig-source:
 	./debian/build-orig.sh





Greetz,

Louis



________________________________

	Van: Martin Krämer [mailto:mk.maddin@xxxxxxxxx]
	Verzonden: maandag 8 april 2019 18:26
	Aan: L.P.H. van Belle
	CC: samba@xxxxxxxxxxxxxxx
	Onderwerp: Re: [Samba] Debian Stretch, Samba 4.10.2, 4.9.6 and 4.8.11 Available (amd64/i386)
	
	
	Hi,

	short question - when running "samba -V" I recieve a version of:
	Version 4.10.2-Ubuntu
	

	But my OS running is Debain 9.8 (stretch) amd64.
	My entry within sources.list is:
	deb http://apt.van-belle.nl/debian stretch-samba410 main contrib non-free
	

	Is this correct / wanted behavior (that version reporting back is 'Ubuntu' even for debian)?
	
	
	I think within the last version (4.10.1) it was already the same.
	(Not sure since I am using your repo for first tests just since yesterday :) )
	
	
	Thanks for providing the updated packages.

	
	

	Am Mo., 8. Apr. 2019 um 15:04 Uhr schrieb L.P.H. van Belle via samba <samba@xxxxxxxxxxxxxxx>:
	

		Hai guys,
		
		I've updated the Debian Stretch package for Samba 4.10.2, 4.9.6 and 4.8.11.
		
		Repo info : https://apt.van-belle.nl
		Build logs: http://downloads.van-belle.nl/samba4/Buildlogs/stretch/
		
		Quick repo setup:
		Optional: apt-get install apt-transport-https
		
		Import my public key:
		wget -O - http://apt.van-belle.nl/louis-van-belle.gpg-key.asc | apt-key add -
		
		# Example repo stretch samba 4.9.x
		echo "deb http://apt.van-belle.nl/debian stretch-samba49 main contrib non-free" | sudo tee /etc/apt/sources.list.d/van-belle.list
		
		Repo names for stretch:
		stretch-samba48
		stretch-samba49
		stretch-samba410
		
		Have fun with them.
		
		Greetz,
		
		Louis
		
		
		--
		To unsubscribe from this list go to the following URL and read the
		instructions:  https://lists.samba.org/mailman/options/samba
		




--
Denis Cardon
Tranquil IT
12 avenue Jules Verne (Bat. A)
44230 Saint Sébastien sur Loire (FRANCE)
tel : +33 (0) 240 975 755
http://www.tranquil.it

Tranquil IT recrute! https://www.tranquil.it/nous-rejoindre/
Samba install wiki for Frenchies : https://dev.tranquil.it
WAPT, software deployment made easy : https://wapt.fr

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba