Web lists-archives.com

[Samba] DNS forwarding not working.




I followed this url to set up Samba AD DC.
https://github.com/thctlo/samba4/blob/master/full-howto-Ubuntu18.04-samba-AD_DC.txt

I do have it working.  I am testing with a Windows 10 VM as a member of 
the domain.
The machine joins the domain.  Also, as administrator, I can create and 
enforce
Group Policies. from this Windows machine.

I have a Fedora 29 server which serves DHCP and DNS (and DDNS).  This all 
works.
When I installed Samba DC, I specified this DNS server as a forwarder.

On the DC server (named dc0) I can enter command,
> dig other_machine_in_lan
and get correct response.
If I enter this command,
> dig @localhost other_machine_in_lan
It fails.  Dig from domain member of course also fails.

I know you may need more information to diagnose, but there are so many 
files that could
be part of the problem I do not know which to send.

I'd appreciate any direction.

Thank you,

Durwin


This email message and any attachments are for the sole use of the 
intended recipient(s) and may contain proprietary and/or confidential 
information which may be privileged or otherwise protected from 
disclosure. Any unauthorized review, use, disclosure or distribution is 
prohibited. If you are not the intended recipient(s), please contact the 
sender by reply email and destroy the original message and any copies of 
the message as well as any attachments to the original message.
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba