Web lists-archives.com

Re: [Samba] Odd behavior since upgrading to 4.9.6




On Wed, 24 Apr 2019 14:53:39 -0500 (CDT)
Mike Ray <mray@xxxxxxxxxxx> wrote:


> > Not sure I understand this, 'samba -b' shows it expects
> > '/var/lib/samba/ntp_signed' but your netstat command shows
> > '/var/run/samba/ntp_signd'. I have to ask, why is this ?
> > I also have to ask why you didn't read the Samba wiki ?
> >   
> 
> I used both the wiki and that blog post. In the wiki, one of the
> first lines reads:
> 
> Verify the socket permissions on your domain controller (DC). The
> time daemon must have read permissions in the ntp_signed directory.
> To list the permissions, enter: # ls
> -ld /usr/local/samba/var/lib/ntp_signd/ drwxr-x--- 2 root ntp 4096
> 1. May 09:30 /usr/local/samba/var/lib/ntp_signd/
> 
> My configuration is not rooted under /usr/local/samba but uses the
> file system directly (e.g. /var/lib/samba).

The wiki is written from the premise that the reader is using a self
compiled Samba version, where the default is for everything to be
placed in /usr/local/samba 

> However, instead of just
> blindly using /var/lib/samba/ntp_signd, I decided I should verify the
> proper directory (as there was a bunch of other cruft from the old
> DCs -- and still is as you have seen). That's when I went searching,
> found the blog and found that it was using /var/run/samba/ntp_signd/.
> It's probably worth noting that I do not believe I set anything to
> force it to use that directory -- in fact I changed the option in
> smb.conf to that value away from /var/lib/samba/ntp_signd AFTER I
> found it with netstat.

I am not knocking what you did, I was trying to understand why it was
the way it was ;-)


> No, these do not appear to be related to tombstones, but valid and
> active objects.
> 
> 
> > 
> > Can you share the output with me ? I may see something you have
> > missed. You can send them to me offlist if required.  
> 
> I'll send it to you offlist.
> 

OK
 
> > You can double check with 'samba-tool ldapcmp'  
> 
> This also runs nightly and has not yet noted any errors since the
> upgrade (~12 days).

This is very strange, everything seems to be okay, but it isn't working
as expected ????

Rowland


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba