Web lists-archives.com

Re: [Samba] winbind offline login - NT_STATUS_NO_SUCH_USER (0xc0000064)




Hi All,

I created bug report below:

https://bugzilla.samba.org/show_bug.cgi?id=13908

Thanks again to Rowland for your input

Am Fr., 19. Apr. 2019 um 14:37 Uhr schrieb Rowland Penny via samba <
samba@xxxxxxxxxxxxxxx>:

> On Fri, 19 Apr 2019 14:17:16 +0200
> Martin Krämer <mk.maddin@xxxxxxxxx> wrote:
>
> > Hi Rowland,
> >
> > > From my understanding (limited as it is when it comes to the 'C'
> > > code), only things in the 'cache' directory are supposed to survive
> > > a reboot, so the thing you need for offline logon, looks like it
> > > has been moved to a directory where it wont.
> > Yes I agree.
> >
> > I checked the commit where this was changed and found the following:
> >
> https://gitlab.com/samba-team/samba/commit/1386200be5c583c680c3894a11688a0e0a3d2285
> >
> > But now - what to do with this?
> > It seems that there was a legit reason for gencache.tdb to be moved
> > and I am not enough expert on C or samba to fully understand why and
> > if that change was correct.
> > (Not needed to say that I see no benefit in "blaming" someone for 'you
> > broke it' - I think everybody does his best here to get samba even
> > better than it already is :) )
> > Never the less it breaks the offline login - so do you think it is
> > worth creating a new bug report?
>
> Yes, you do at least know what the problem is and when it was changed.
>
> >
> > I searched some more and found a bug report (
> > https://bugzilla.samba.org/show_bug.cgi?id=10455)
> > that from my point of view seems to be related to one of the first
> > lists.samba.org links I referenced to
> > https://lists.samba.org/archive/samba/2019-February/221157.html
> > What I have read there in it still could be possible that the root
> > cause is the same - even when I am personally missing some more
> > details on which versions were checked on the last state update etc.
> > But I am absolutely not sure if it is preferred by samba devs to
> > "extend" an existing bug or just create a new one and reference...
>
> I don't think they have anything to do with this current problem, as I
> said, I am using 4.8.9 and offline logon works for me.
>
> >
> > PS: You replied off list - was this a mistake or did you just not
> > want all your comments available to the "world"? As someone facing
> > issues I am always happy to find "old" entries in lists that provide
> > any usable information :)
>
> No, I didn't, I replied to the list (I have checked)
> >
>
> Rowland
>
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba
>
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba