Web lists-archives.com

Re: [Samba] GPO Filtering Denied




On Fri, 19 Apr 2019 08:55:43 -0600
durwin@xxxxxxxxxxxxxxx wrote:

> > From: Rowland Penny via samba <samba@xxxxxxxxxxxxxxx>
> > To: samba@xxxxxxxxxxxxxxx
> > Date: 04/19/2019 08:29 AM
> > Subject: Re: [Samba] GPO Filtering Denied
> > Sent by: "samba" <samba-bounces@xxxxxxxxxxxxxxx>
> > 
> > On Fri, 19 Apr 2019 08:00:32 -0600
> > Durwin via samba <samba@xxxxxxxxxxxxxxx> wrote:
> >   
> > > I followed Part 1, Part 3, and Part 4 at this url
> > > 
> > > https://www.tecmint.com/install-samba4-active-directory-ubuntu/
> > > 
> > > Domain Controller is Fedora 29 with samba-dc-4.9.6-0 installed,
> > > the other Windows 10 Pro version 1809 with RSAT installed.  
> > 
> > Would these be the default Fedora Samba packages ? using MIT ?  
> 
> Yes, I am using default packages from Fedora 29.  What is MIT?

There are two opensource kerberos servers, one is MIT, which is the
default on red-hat distros, the other is Heimdal, which is the default
for Samba. After a lot of work, Fedora is now using MIT with Samba, but
there is still a lot more to do, so it is recommended to only use the
Fedora packages for testing and Samba with MIT is marked as
experimental.

> 
> What are my other choices?  Compile from source?

You can compile from source, but this would entail either creating your
own RPM's or setting the configure options to place Samba into where
Fedora expects it to be (which could be overwritten by a later distro
update) or just running './configure' which would place Samba entirely
into /usr/local/samba. You could also try to find a repo that supplies
Fedora RPM's that use Heimdal.

Another option is to use a distro that has always used Heimdal, Debian
is such a distro, but their Samba packages are bit old, this isn't a
big problem, you can find later Samba packages here:

http://apt.van-belle.nl/

Rowland


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba