Web lists-archives.com

Re: [Samba] Windows / / Windows 10 randomly lost connection to Samba share




I have set

 grep client /etc/samba/smb.conf
    client min protocol = SMB2
    client max protocol = SMB2

stop and start samba but connections are still smb3_11

/etc/init.d/samba stop
[ ok ] Stopping smbd (via systemctl): smbd.service.
[ ok ] Stopping nmbd (via systemctl): nmbd.service.
/etc/init.d/samba start
[ ok ] Starting nmbd (via systemctl): nmbd.service.
[ ok ] Starting smbd (via systemctl): smbd.service.
root@kes-srv-031:~# smbstatus

Samba version 4.5.16-Debian
PID     Username     Group        Machine
    Protocol Version  Encryption           Signing
----------------------------------------------------------------------------------------------------------------------------------------

Service      pid     Machine       Connected at
Encryption   Signing
---------------------------------------------------------------------------------------------

No locked files

smbstatus

Samba version 4.5.16-Debian
PID     Username     Group        Machine
    Protocol Version  Encryption           Signing
----------------------------------------------------------------------------------------------------------------------------------------
26314   admin        domain admins 192.168.30.99
(ipv4:192.168.30.99:64444)  SMB3_11           -
partial(AES-128-CMAC)



On 08.04.19 16:47, basti via samba wrote:
> 
> 
> On 08.04.19 16:20, L.P.H. van Belle via samba wrote:
>> Hai Basti,
>>
>> Anything in the windows even logs? 
>> This might be related to smb1 and windows automaticly removing it.  
> 
> smbstatus say that all open connections are SMB2_10 and SMB3_11
> the windows log say: german text and errorcode C0000006
> 
>>
>> Or something else. 
>> Can you check with mtr from a windows pc to the server.
>> And same check from server to winpc so your sure its not a defective network component.
> 
> The Problem is on more than one client. All clients are win10. I think
> is is a Problem with 4.5.16-Debian and SMB3_11.
> 
> I will try to set client max protocol to SMB2_10
> 
>> And a side notice, i recommend you to upgrade to 4.8 or 4.9. 
> I will do it when buster is released.
>>
>> Greetz, 
>>
>> Louis
>>
>>
>>
>>
>>> -----Oorspronkelijk bericht-----
>>> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens 
>>> basti via samba
>>> Verzonden: maandag 8 april 2019 12:47
>>> Aan: samba@xxxxxxxxxxxxxxx
>>> Onderwerp: [Samba] Windows / / Windows 10 randomly lost 
>>> connection to Samba share
>>>
>>> hello,
>>>
>>> we have a samba AD DC and some samba fileservers.
>>>
>>> Version: 4.5.16-Debian (van belle repo)
>>> Debaian version: 9.8
>>>
>>> Some clients windows 7 and windows 10 randomly lost 
>>> connection to share.
>>> Loglevel is set to 3.
>>> But i can't find any relevant entries in the log.
>>> How can i debug the connection lost?
>>>
>>> Best regards;
>>>
>>> -- 
>>> To unsubscribe from this list go to the following URL and read the
>>> instructions:  https://lists.samba.org/mailman/options/samba
>>>
>>>
>>
>>
> 

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba