Web lists-archives.com

Re: [Samba] error in samba 4.10.0 while using samba-tool domain provision




On Fri, 5 Apr 2019 23:05:33 +0800
adam_xu--- via samba <samba@xxxxxxxxxxxxxxx> wrote:

> Hi ,
> 
> you need to install these packages(epel repo enabled):
> yum install attr bind-utils docbook-style-xsl gcc gdb
> krb5-workstation \ libsemanage-python libxslt perl
> perl-ExtUtils-MakeMaker lmdb-devel libarchive-devel \ perl-Parse-Yapp
> perl-Test-Base pkgconfig policycoreutils-python pygpgme \
> python2-crypto gnutls-devel gpgme-devel jansson-devel libattr-devel
> keyutils-libs-devel \ libacl-devel libaio-devel libblkid-devel
> libxml2-devel openldap-devel libtasn1-tools \ pam-devel popt-devel
> python-devel readline-devel zlib-devel systemd-devel \ python-dns
> 
> It has been tested using python2 in centos7. 
> 

The problem with that is, whilst Samba 4.10.x will work with python2,
Samba 4.11.0 (when it is released in about 6 months time) wont. At that
point, Samba will require python3, so you either need to fix it now or
use another distro. I say this because RHEL has already said that there
will never be distro Samba packages that will be able to provision as a
DC.

Rowland

 

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba