Web lists-archives.com

Re: [Samba] selftest




On Tue, 2 Apr 2019 15:48:41 +0000 (UTC)
Billy Bob <billysbobs@xxxxxxxxx> wrote:

> > On Mon, 1 Apr 2019 21:49:06 +0000 (UTC)
> > Billy Bob via samba <samba@xxxxxxxxxxxxxxx> wrote:
> >   
> > > > While 'make test' is intended to> pass generally, the reference
> > > > environment is Ubuntu 14.04 (soon to be> upgraded to 18.04 for
> > > > the next release).    
> > > 
> > > By "next release," do you mean 4.10.1 or 4.11?
> > > 
> > > Looking also at
> > > https://lists.samba.org/archive/samba/2019-April/222157.html is
> > > there concern that 4.10.0 is not production-ready on Ubuntu 18.04?
> > >   
> > 
> > No, I just wasn't building Samba into the default prefix
> > '/usr/local/samba', so I had to backport various Samba packages from
> > 18.10 before it would build. I have no doubt that if I had run
> > './configure && make && sudo make install', it would have worked.
> > 
> > The point of the post you referred to, was that RHEL 7.x probably
> > isn't production ready for 4.10.0
> >   
> Rowland,
> Three things:
> 1) would you share your build notes with me (v. 4.10.0 on Ubuntu
> 18.04)? 

Yes, but there isn't much point now, Louis has released his Ubuntu
packages and these will replace any ubuntu packages already installed.

>2) do you have any insight re: the version expected to have
> the 'make test' fix (earlier question above directed to Andrew)?

No, this is more in Andrews field of expertise than mine, but I don't
really understand why you require this. It is really meant to ensure
that the developers don't break things, it isn't required to run Samba
in production.

> 3)
> can you provide any insights on pros/cons of configuring as default
> vs. configuring with fhs when building on Ubuntu 18.04? I note (a)
> with respect to default, your comment regarding Ubuntu still
> expecting some distro packages and (b) that you and Louis both seem
> to configure fhs. On the other hand, it seems that there is more to
> the fhs configuration, e.g. the "backport" requirements. Would
> appreciate some more in-depth discussion of these
> particular considerations and concomitant issues (either here or in a
> further/follow up to you previous answer to
> https://lists.samba.org/archive/samba/2019-April/222172.html ;). Thank
> you, as always

I only built Samba 4.10.0 using the FHS because it seemed it was a
problem, I normally just build Samba into /usr/local/samba but I don't
build it much nowadays, I use Louis's packages ;-)

As for an 'fhs' build, this may just work, but if you have an earlier
Samba version installed before the build, then watch out for updates.
If you build into /usr/local/samba then various things do not work as
expected.

As for backporting packages from Disco, it isn't quite straight
forward, 18.04 comes with python3.6 and 18.10 comes with python3.7,
so a few files have to be modified.

Rowland
  


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba