Web lists-archives.com

Re: [Samba] Attempts to Set Max Password Age in Samba Tool Fails




On Fri, 29 Mar 2019 15:45:57 -0500
Matthew Delfino via samba <samba@xxxxxxxxxxxxxxx> wrote:

> Hello!
> 
> 
> I am on Samba 4.10.0, Ubuntu 16.04.2 LTS. I recently reset a password
> and found that my password expiration had somehow gotten set to 400
> days.

Where did you get the Samba 4.10.0 packages from ?

> 
> I went to one of my DCs and ran the following command:
> 
> 
> 
> # samba-tool domain passwordsettings show
> Password informations for domain 'DC=samdom,DC=mydomain,DC=com'
> 
> 
> Password complexity: on
> Store plaintext passwords: off
> Password history length: 5
> Minimum password length: 14
> Minimum password age (days): 0
> Maximum password age (days): 400
> Account lockout duration (mins): 60
> Account lockout threshold (attempts): 30
> Reset account lockout after (mins): 60
> 
> 
> That needed to change so, I tried to enforce my company's policy:
> 
> 
> 
> # samba-tool domain passwordsettings set --max-pwd-age=270
> ERROR(<class 'TypeError'>): uncaught exception - unorderable types:
> NoneType() >= int() File
> "/usr/lib/python3/dist-packages/samba/netcmd/__init__.py", line 184,
> in _run return self.run(*args, **kwargs) File
> "/usr/lib/python3/dist-packages/samba/netcmd/domain.py", line 1513,
> in run if max_pwd_age and max_pwd_age > 0 and min_pwd_age >=
> max_pwd_age:

What Python 3 packages are installed ?

Rowland


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba