Web lists-archives.com

Re: [Samba] samba 4.9.5 - joining Samba DC to existing Samba AD failed (ldbsearch has not -U and -V)




On Wed, Mar 27, 2019 at 9:11 AM Rowland Penny via samba
<samba@xxxxxxxxxxxxxxx> wrote:
>
> On Wed, 27 Mar 2019 13:00:42 +0100
> Franta Hanzlík <franta@xxxxxxxxxxx> wrote:
>
> > Yes, is no difference between '-UAdministrator' and '-U
> > Administrator'. But it seems, as ldbsearch in 4.9.5 is different than
> > 4.9.4-. (I was furious with that, because I found lot articles on
> > net, where -U _username_ was stated.
> >
> > My ldbsearch is from pure Samba-4.9.5, self compiled on Fedora 29
> > x86_64. And now I see it even has not '-V' switch:

Franta, if you're trying to build on Fedora 29, would you consider
trying my "master" branch of https://github.com/nkadel/samba4repo ?
I've been trying to update it to 4.9.5, and a separate branch for
4.10.0, with Fedora 29 and the RHEL 8 beta lately. The Python3
requirements of 4.10.0 are a serious problem for RHEL 7, but there are
othe issues for Fedora for that even more recent release.

Also, unless you actually build and install RPM's a manual build is
vulnerable to all sorts of PATH and LD_LIBRARY_PATH issues if any if
the original RPM's are sstill present on Fedora and RHEL.

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba