Web lists-archives.com

Re: [Samba] Samba 4.8 Config SMB.Conf File




I am having similar issues going form 4.7.12 to 4.8.9

Previous smb.conf on a member server just no longer IDs users.

wbinfo -u and wbinfo -g return proper information; however, id does not.

The error appears to be in mapping SIDs.

# wbinfo -n user
<sid>
# wbinfo -S <sid>
ailed to call wbcSidToUid: WBC_ERR_DOMAIN_NOT_FOUND
Could not convert sid <sid> to uid


Notably, I do use the 'ad' backend.


Tyrus -- does "wbinfo -S <sid>" work for you?


----- On Mar 14, 2019, at 12:58 PM, samba samba@xxxxxxxxxxxxxxx wrote:

> On Thu, 14 Mar 2019 13:39:31 -0400
> Tyrus Shivers <tyrus.shivers@xxxxxxxxxxxxxxx> wrote:
> 
>> removed sssd.
>> removed all sss occurrences and winbind from the shadow line.
>> Selinux is disabled.
>> firewalld is disabled.
>> 
>> not sure if there is a difference but I have smb and winbind, I do
>> not have nmbd or smbd.
>> 
>> /etc/resolv.conf
>> 
>> search mydomain.com
>> nameserver "ipaddress for DC1"
>> nameserver "ipaddress for DC2"
>> 
>> Still no such user after restarting the services and executing net
>> cache flush.
>> 
> 
> This is very strange, it normally just works, it is usually the 'ad'
> backend that gives trouble.
> 
> When you posted your smb.conf, you didn't head it with '[global]', I
> take it that is there.
> 
> Have you tried running 'testparm' just in case there is a typo or
> something.
> 
> Have you tried leaving and rejoining the domain.
> 
> Does 'wbinfo -u | grep username' produce output ?
> 
> Rowland
> 
> 
> 
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba