Web lists-archives.com

[Samba] samba-tool domain provision stuck when using python3




Hello, everyone. 
    I am testing  samba 4.10RC4's the compatibility with python3. I compiled samba 4.10rc4 successfully in CentOS7.6 with Python3.6.6. but when I run
samba-tool domain provision --use-rfc2307 --interactive
It stuck and did not give any error messages.
then I enable debug
samba-tool domain provision --use-rfc2307 --interactive -d7
it throw info like:
INFO: Current debug levels: all: 7 tdb: 7 printdrivers: 7 lanman: 7 smb: 7 rpc_parse: 7 rpc_srv: 7 rpc_cli: 7 passdb: 7 sam: 7 auth: 7 winbind: 7 vfs: 7 idmap: 7 quota: 7 acls: 7 locking: 7 msdfs: 7 dmapi: 7 registry: 7 scavenger: 7 dns: 7 ldb: 7 tevent: 7 auth_audit: 7 auth_json_audit: 7 kerberos: 7 drs_repl: 7 smb2: 7 smb2_credits: 7 dsdb_audit: 7 dsdb_json_audit: 7 dsdb_password_audit: 7 dsdb_password_json_audit: 7 dsdb_transaction_audit: 7 dsdb_transaction_json_audit: 7 dsdb_group_audit: 7 dsdb_group_json_audit: 7 

and it didn't go on.

here's my step to complile samba 4.10rc4.
1 install some packages from repos with epel enabled.
yum install attr bind-utils docbook-style-xsl gcc gdb krb5-workstation \
libxslt perl perl-ExtUtils-MakeMaker lmdb-devel libarchive-devel \
perl-Parse-Yapp perl-Test-Base pkgconfig  libtasn1-tools \
gnutls-devel gpgme-devel jansson-devel libattr-devel keyutils-libs-devel \
libacl-devel libaio-devel libblkid-devel libxml2-devel openldap-devel \
pam-devel popt-devel readline-devel zlib-devel systemd-devel \
python36-devel python36-pip python36-requests
# the python36 packages are in the epel repo.

2 install some python packages as there're no these packages in the repo (python36 version).
pip3.6 install crypto pygpgme

3 compile samba.
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libdir=/usr/lib64 \
--enable-fhs --with-lockdir=/var/lib/samba/lock --with-cachedir=/var/lib/samba \
--with-piddir=/run --with-gpgme --with-systemd --disable-cups --systemd-install-services
# there's no errors during the compilation process.

4 domain provision
samba-tool domain provision --use-rfc2307 --interactive

it just stuck but did not throw any error.

And when I compile samba 4.10RC4 with python2.7. everything is OK.

could you give any professional suggestion ? thanks.




yours Adam
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba