Web lists-archives.com

Re: [Samba] hostname is missing in the output from "smbstatus -b"




Hello Rowland,
thanks for answering so fast.

> >
> > we have migrated our Samba server from version 3.6 to Samba 4.6.
> >
> > Everyting is working fine, but I have seen one difference in the
> > output from "smbstatus -b".
> >
> > The hostname in the output is no longer displayed (see examples below)
> > 1) The hostname must come from Session setup or similar, because we
> > don't have any
> >  name resolution for clients.
> > 2) The hostname from the clients is usefull for us, because a lot of
> > clients are behind a NAT-Gateway and comes with one IP ( in example
> > the 192.168.12.30) ! In the old version I could see from witch host
> > each user came.
> >
> > In the new version, I only see the IP address two times.
> >
>
> This may be an artefact of turning off NTLMv1,
So there is nowedays no possibility to track, from witch
client name the connection comes (behind a NAT Gateway)?

> try adding 'ntlm auth =
> yes' to your smb.conf and restarting Samba. If this cures your problem,
> then you have to decide if you can run with an insecure set up.

This option is turned on already.
I know, this is a total ugly, insecure setup, but we have to run a
single samba for
W2k3 Terminal Servers and Windows XP-Clients (max protocol = NT1 ntlm
auth = yes, backend ldap).
That is a "border server" for exchanging documents between two
untrusted companies.
( I would love to turn off the server immediately, but I can't)

> I would also urge you to consider upgrading again, but this time to AD.
(We have running a AD internaly ...)

Thanks Meike

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba