Web lists-archives.com

Re: [Samba] Setting 'unix charset' kills the samba share




This is on Centos 7.4

I see this when I start smbd :

[root@zinc samba]# systemctl status smb.service
* smb.service - Samba SMB Daemon
   Loaded: loaded (/usr/lib/systemd/system/smb.service; disabled; vendor
preset: disabled)
   Active: failed (Result: exit-code) since Mon 2019-01-14 15:19:01 EST;
13s ago
     Docs: man:smbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 9214 ExecStart=/usr/sbin/smbd --foreground --no-process-group
$SMBDOPTIONS (code=exited, status=1/FAILURE)
 Main PID: 9214 (code=exited, status=1/FAILURE)
   Status: "daemon failed to start: Samba cannot setup ep pipe"
    Error: 13 (Permission denied)


I changed the log level to 3 to reduce the size. I see this in  log.smbd:

[2019/01/14 15:25:16.815832,  3]
../source3/param/loadparm.c:3868(lp_load_ex)
  lp_load_ex: refreshing parameters
[2019/01/14 15:25:16.815916,  3]
../source3/param/loadparm.c:547(init_globals)
  Initialising global parameters
[2019/01/14 15:25:16.816020,  3]
../source3/param/loadparm.c:2782(lp_do_section)
  Processing section "[global]"
[2019/01/14 15:25:16.816320,  2]
../source3/param/loadparm.c:2799(lp_do_section)
  Processing section "[zinc1]"
[2019/01/14 15:25:16.816639,  3]
../source3/param/loadparm.c:1617(lp_add_ipc)
  adding IPC service
[2019/01/14 15:25:16.817843,  2]
../source3/lib/interface.c:345(add_interface)
  added interface enp3s0 ip=192.168.0.86 bcast=192.168.0.255
netmask=255.255.255.0
[2019/01/14 15:25:16.817927,  3] ../source3/smbd/server.c:1808(main)
  loaded services
[2019/01/14 15:25:16.822923,  1]
../source3/profile/profile.c:51(set_profile_level)
  INFO: Profiling turned OFF from pid 9920
[2019/01/14 15:25:16.822988,  3] ../source3/smbd/server.c:1828(main)
  Standard input is not a socket, assuming -D option
[2019/01/14 15:25:16.823010,  3] ../source3/smbd/server.c:1840(main)
  Becoming a daemon.
[2019/01/14 15:25:16.824338,  2]
../source3/passdb/pdb_interface.c:161(make_pdb_method_name)
  No builtin backend found, trying to load plugin
[2019/01/14 15:25:16.826645,  3]
../lib/util/modules.c:167(load_module_absolute_path)
  load_module_absolute_path: Module '/usr/lib64/samba/pdb/tdbsam.so' loaded
[2019/01/14 15:25:16.844869,  3]
../source3/lib/util_procid.c:54(pid_to_procid)
  pid_to_procid: messaging_dgm_get_unique failed: No such file or directory
[2019/01/14 15:25:16.860524,  3]
../source3/rpc_server/svcctl/srv_svcctl_reg.c:565(svcctl_init_winreg)
  Initialise the svcctl registry keys if needed.
[2019/01/14 15:25:16.861144,  0]
../lib/util/charset/convert_string.c:391(convert_string_talloc_handle)
  convert_string_talloc: Conversion not supported.
[2019/01/14 15:25:16.861545,  1] ../librpc/ndr/ndr.c:615(ndr_pull_error)
  ndr_pull_error(5): Bad character conversion
[2019/01/14 15:25:16.861575,  0]
../source3/auth/auth_util.c:1696(copy_session_info)
  copy_session_info(): ndr_pull_auth_session_info failed: Character
Conversion Error
[2019/01/14 15:25:16.861625,  0]
../source3/rpc_server/rpc_ncacn_np.c:238(make_internal_rpc_pipe_p)
  open_rpc_pipe_p: copy_serverinfo failed
[2019/01/14 15:25:16.861683,  0]
../source3/rpc_client/cli_winreg_int.c:124(_winreg_int_openkey)
  dcerpc_winreg_int_openkey: Could not connect to winreg pipe:
NT_STATUS_NO_MEMORY
[2019/01/14 15:25:16.861738,  0]
../source3/rpc_server/svcctl/srv_svcctl_reg.c:600(svcctl_init_winreg)
  svcctl_init_winreg: Could not open SYSTEM\CurrentControlSet\Services -
NT_STATUS_NO_MEMORY
[2019/01/14 15:25:16.861803,  0]
../source3/rpc_server/srv_pipe_register.c:222(rpc_srv_register)
  rpc_srv_register: Failed to call the svcctl init function!
[2019/01/14 15:25:16.862079,  0]
../lib/util/become_daemon.c:124(exit_daemon)
  exit_daemon: STATUS=daemon failed to start: Samba cannot setup ep pipe,
error code 13



This seems interesting:

[2019/01/14 15:25:16.861144,  0]
../lib/util/charset/convert_string.c:391(convert_string_talloc_handle)
  convert_string_talloc: Conversion not supported.


But what values are supported ?


Le lun. 14 janv. 2019 à 14:47, Gilbert Soucy <gsoucy@xxxxxxxxx> a écrit :

>
> Hello,
>
> When I define
>
>
> *unix charset = ISO-8859-1*
>
> in *smb.conf*, it does not work. When I comment it, the share works fine.
> However, we need to define the charset...
>
> When unix charset is
>
>
> Here is the global section of smb.conf
>
> [global]
>
>   workgroup = COMPANY
>   realm = COMPANY.COM
>   security = ADS
>
>
>    winbind use default domain = true
>    winbind offline logon = true
>
>    idmap config * : backend = tdb
>    idmap config * : range = 0-499
>    idmap config COMPANY:backend = ad
>    idmap config COMPANY:schema_mode = rfc2307
>    idmap config COMPANY:range = 500-20000
>    idmap config COMPANY:unix_nss_info = yes
>
>    encrypt passwords = yes
>
>    template shell = /bin/bash
>    template homedir = /home/%U
>
>    log level = 5
>    log file = /var/log/samba/log.%m
>    strict locking = no
>    unix extensions = no
>    dos charset = cp850
>
>    # need to comment out this to get it to wrok
>
>    unix charset = ISO-8859-1
>
>
> We are running smbd 4.8.3. Previously, we had  4.2.3 and  this
>
>      unix charset = ISO8859-1
>
> was ok.   I found this posting  :
> https://www.ibm.com/developerworks/community/forums/html/topic?id=bcba0bd5-2b44-454a-8d56-fea725b3974e
>
> saying that we should use:
>
>      unix charset = ISO-8859-1
>
>  but it does not work for us.
>
> Any idea ?
>
> Thanks
>
> Gilbert
>
>
>
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba