Web lists-archives.com

Re: [Samba] After upgrade to 4.9.4, internal DNS no longer working




On Sun, 23 Dec 2018 10:38:05 +0100
Viktor Trojanovic <viktor@xxxxxxxx> wrote:

> I'm not aware of a new folder being created. I can confirm that
> /var/lib/samba/private/sam.ldb is the only file with that name on my
> system. How could I check if Samba indeed looks up this file and is
> not looking for it somewhere else?
> 
> Some additional information that might be relevant or not. I can run
> ldbsearch -H on sam.ldb without errors. I can even query specific
> information, such as '(objectclass=person)' and the result list looks
> accurate. Doesn't this mean that my sam.ldb is actually in order and
> the error lies elsewhere?
> 

It sort of sounded like your latest Samba was using a different folder,
but it seems it isn't.

If everything in sam.ldb is readable, then it is probably okay, have
you tried running 'samba-tool dbcheck' on it ?

I wonder if your old Samba was <= 4.7.x. A new GUID index mode was
introduced at 4.8.0, but this should just slow things down at first
start up.

There was also a change of ports used at 4.7.0, so if there is a
firewall in use, this could be your problem, see here:

https://wiki.samba.org/index.php/Samba_AD_DC_Port_Usage

You also posted in your smb.conf:

realm = samdom.example.com

Yet, in your other posts, you have this:

DC=samdom,DC=example,DC=ch

Which would make your dns domain (and realm) 'samdom.example.ch', I
take it this is a typo.

Rowland

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba