Web lists-archives.com

[Samba] Ubuntu bionic 18.04 Samba 4.9.4 now available amd64 ( update also on the debian packages.)




Hai, 

The ubuntu bionic 1804 packages are also available now. 
I've include the fix for the start problem at install. 

smbd: fails if winbind is running on default install: create_local_token failed: NT_STATUS_ACCESS_DENIED 
https://bugzilla.samba.org/show_bug.cgi?id=13697 

And the debian stretch packages 4.9.4 are also updated with the fix. 

Greetz, 

Louis
 

> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens 
> L.P.H. van Belle via samba
> Verzonden: donderdag 20 december 2018 15:16
> Aan: samba@xxxxxxxxxxxxxxx
> Onderwerp: [Samba] Debian Stretch Samba 4.9.4 now available amd64/i386
> 
> Hai, 
> 
> I've updated the repo with the Debian Stretch 4.9.4 packages. 
> No changes on my side, so check the samba changelogs for whats fixed. 
> 
> Info : https://apt.van-belle.nl
> Buildlogs : https://downloads.van-belle.nl/samba4/Buildlogs/stretch/ 
> 
> The repo setup.
> 
> 1) Choose http or https for you apt, both work, for https you 
> need to :
> apt-get install apt-transport-https
> 
> 2) Import my public key
> wget -O - http://apt.van-belle.nl/louis-van-belle.gpg-key.asc 
> | apt-key add -
> Or pull my key from the pgp.mit.edu server.  
> apt-key adv --keyserver pgp.mit.edu --recv-keys 0xE6F6A3C7EB7A89CF 
> 
> 3) (optional) setup a header line for the repo file.
> echo "# AptVanBelle repo for samba." | sudo tee 
> /etc/apt/sources.list.d/van-belle.list
> 
> 4) In the line below, change the OS and/or samba version to 
> what you want. Shown is debian stretch with samba 4.9.
> echo "deb http://apt.van-belle.nl/debian stretch-samba49 main 
> contrib non-free" | sudo tee -a /etc/apt/sources.list.d/van-belle.list
> 
> 
> ====>>  PLEASE TAKE NOTE OF THE FOLLOWING. <<====
> All terms like (jessie) and (jessie-backports) and (unstable) 
> are related to this apt-repo (apt.van-belle.nl) are now 
> absolete as of 21-08-2018.
> Also (stretch), (stretch-backports) and (stretch-unstable) 
> are now absolete as of 24-08-2018.
> As of 1 Jan 2019 the old names will be removed. 
> Why: The old repos needed one another, the new repos contain 
> all you need in one repo.
> It is saving me some traffic and better to handle. 
> 
> Dont hammer the server, you will get blocked automaticly if 
> you do so. ( for 1 day ). 
> 
> Repo names changes overview for apt.van-belle.nl.
> 
> The old and should not be use anymore repo's. 
> For Debian Jessie amd64/i386 
> 4.5 jessie-backports: samba 4.5.12 was a backport from 
> stretch, EOL. Not supported/updated anymore.
> 4.5 jessie-samba45  : samba 4.5.16 from samba.org, with 
> latest 2 CVE's from Debian samba 4.5.12.  Not 
> supported/updated anymore as of per today. 
> 
> Up2date repo's. 
> 
> 4.6 oldrepo name : unstable, new repo name     : jessie-samba46
> 4.7 : jessie-samba47
> 4.8 : jessie-samba48
> 
> For Debian Stretch  amd64/i386 .
> 4.6 oldrepo name : stretch, new repo name        : stretch-samba46
> 4.7 oldrepo name : stretch-unable, new repo name : stretch-samba47
> 4.8 : stretch-samba48
> 4.9 : stretch-samba49
> 
> Ubuntu Bionic : 
> 4.9 amd64 only. : repo name   : bionic-samba49 
> 
> Upgradeing from Debian Jessie advice.
> Read : 
> https://downloads.van-belle.nl/samba4/Upgrade-info.txt 
> Now update your smb.conf and update you samba to samba 4.8.
> When that's done and samba is at 4.8, then upgrade to debian stretch. 
> 
> Ubuntu bionic packages 4.9.4 can be expected at latest Friday. 
> Working on them now. 
> 
> 
> Greetz, 
> 
> Louis
> 
> 
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba
> 


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba