Web lists-archives.com

Re: [Samba] smbclient v3 against samba server v4




Il giorno mer 19 dic 2018 13:11:50 CET, Rowland Penny via samba ha scritto:

On Wed, 19 Dec 2018 11:20:30 +0000
Andrea Zagli <azagli@xxxxxxxxx> wrote:

Il giorno mer 19 dic 2018 11:46:56 CET, Rowland Penny via samba ha
scritto:

> On Wed, 19 Dec 2018 09:31:38 +0000
> Andrea Zagli via samba <samba@xxxxxxxxxxxxxxx> wrote:
>
>> hi all
>>
>> i'm trying to use smbclient v3 with a samba server v4 configured
>> as ad
>>
>> with anonymous login it works; but it doesn't using a user
>>
>> i get NT_STATUS_LOGON_FAILURE
>>
>> the pc isn't in the domain; but i tried from a non domain pc with
>> smbclient v4 and it works
>
> I think you have answered yourself, it doesn't work with smbclient
> v3 (by which, I take it you mean from a Samba 3.x.x version), but
> it does with smbclient v4. There have been a great many changes
> between Samba 3.x.x and now and it is probably at least one of
> these changes that is stopping it working.

so the next questions are:
- winbind v3 could authenticate against samba v4 ad?

Samba 3.6.x should be able to authenticate from an AD domain, I
believe the same goes for 3.5.x

or i could
simply use nsswitch with ldap (as with a samba v3 server)?

Probably, never tried it, nslcd works against AD

- samba v3 can join a samba v4 ad?

Samba 3.6.x has been known to join an AD domain, not sure about 3.5.x


> The only versions that Samba supports are 4.7.x, 4.8.x and 4.9.x,
> all others are supported by the OS's
>
> Having said all that, we may be able to help you, if you give us
> more info ;-)
>
> What OS is smbclient v3 running on and what is in its smb.conf (not
> that the latter should affect smbclient)
> What OS is the Samba AD DC running on and what is in its smb.conf.
>

smbclient V3
  - debian 6.0.10
  - smbclient 3.5.6

Both Squeeze & Samba 3.5.x are EOL, can I suggest you upgrade to the
latest Debian version. You can also find the latest Samba version here:



unfortunately i cannot upgrade to samba 4 on these client pc

but i upgraded to samba 3.6.6 and now it seems to work (at least smbclient; asap i'll try other aspects)

thanks a lot

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba