Web lists-archives.com

Re: [Samba] Build error while upgrading samba 4.9.3




On Thu, 2018-12-06 at 11:28 +0100, L.P.H. van Belle via samba wrote:
> Im wondering this also. 
> 
> Why are you using wheezy for samba AD.. 
> You need to fix all needed depends first before you can even thing compiling samba. 
> 
> A few snaps out your attempt to build. 
> 
> Checking for program xsltproc                                                     : not found
> Checking for system cmocka (>=1.1.1)                                              : not found
> Checking for system z (>=1.2.3)                                                   : not found
> Checking for system tdb (>=1.3.16)                                                : not found
> Checking for system talloc (>=2.1.14)                                             : not found
> 
> Run these 2 command in the source folder.
> grep ^VERSION lib/{talloc,tdb,tevent,ldb}/wscript
> grep minversion buildtools/wafsamba/samba_third_party.py | awk -F"(" '{ print $2 }'
> 
> These are the minimal required depend versions. 
> And now think again if you want to attempt this because the few shown above are not the only things you will encounter.

To be clear, these libraries are bundled with Samba, the error is not
fatal, we just use the system one if is is recent enough. 

I think the real error here comes from the old C compiler not liking
something that rpcgen, an xDR compiler, generates.  

Clearly Samba 4.9 is no longer compatible with this old system, or
rpcgen is not installed.  

If the error is the latter, a configure test would be grand, to error
out during configure.

I hope this clarifies things,

Andrew Bartlett

-- 
Andrew Bartlett
https://samba.org/~abartlet/
Authentication Developer, Samba Team         https://samba.org
Samba Development and Support, Catalyst IT   
https://catalyst.net.nz/services/samba





-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba