Web lists-archives.com

Re: [Samba] Cannot scan to network share from Canon




On Thu, 6 Dec 2018 12:52:24 +0100
Matthew Broadhead via samba <samba@xxxxxxxxxxxxxxx> wrote:

> without comments
> 
> [global]
>      workgroup = NBMDARTFORD
>      server string = Samba Server Version %v
>      netbios name = SCARECROW
>      log file = /var/log/samba/log.%m
>      max log size = 50
> 
>      security = user
>      passdb backend = tdbsam
> 
>      map to guest = Bad User
>      guest account = nobody
> 
>      domain master = yes
>      domain logons = yes
>      logon path = \\%L\Profiles\%U
>      logon drive = H:
>      logon home = \\%L\%U
> 
>      add user script = /usr/sbin/useradd "%u" -n -g users
>      add group script = /usr/sbin/groupadd "%g"
>      add machine script = /usr/sbin/useradd -n -c "Workstation (%u)"
> -M -d /nohome -s /bin/false "%u"
>      delete user script = /usr/sbin/userdel "%u"
>      delete user from group script = /usr/sbin/userdel "%u" "%g"
>      delete group script = /usr/sbin/groupdel "%g"
> 
> admin users = richard.broadhead
> 
>      wins support = yes
>      load printers = yes
>      cups options = raw
> 
> [homes]
>      comment = Home Directories
>      browseable = no
>      writable = yes
>      valid users = %S
> 
> [printers]
>      comment = All Printers
>      path = /var/spool/samba
>      browseable = no
>      guest ok = no
>      writable = no
>      printable = yes
> 
>      [netlogon]
>      comment = Network Logon Service
>      path = /var/lib/samba/netlogon
> 
>      [Profiles]
>      path = /var/lib/samba/profiles
>      browseable = no
>      read only = no
>      profile acls = yes
> 
> [software]
>      path = /home/software
>      read only = no
>      valid users = @users
>      write list = @users
>      browseable = no
>      create mask = 0664
>          force directory mode = 0775
> 
> [legal]
>      path = /home/legal
>      read only = no
>      valid users = @users
>      write list = @users
>      writable = yes
>      create mask = 0664
>          force directory mode = 0775
> 
> [laserform]
>      path = /home/laserform
>      read only = no
>      valid users = @users
>      valid users = +users
>      force create mode = 770
> 
> [applications]
>      path = /home/applications
>      read only = no
>      guest ok = yes
> 
> [scans]
>      path = /home/scans
>      read only = no
>      guest ok = yes
>      public = yes
> 

Is winbind running ?

try adding :

client max protocol = NT1

to your smb.conf and remove:

profile acls = yes

You should also seriously consider upgrading your PDC domain to an
active directory domain, it is getting harder & harder to keep the
NT4-style domains working.

Rowland


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba