Web lists-archives.com

Re: [Samba] Required to Build Samba




 

> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens 
> Rowland Penny via samba
> Verzonden: dinsdag 4 december 2018 10:13
> Aan: samba@xxxxxxxxxxxxxxx
> Onderwerp: Re: [Samba] Required to Build Samba
> 
> On Tue, 4 Dec 2018 09:24:30 +0100
> "L.P.H. van Belle via samba" <samba@xxxxxxxxxxxxxxx> wrote:
> 
> > Hai Barry, 
> > 
> > > -----Oorspronkelijk bericht-----
> > > Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens 
> > > Barry D. Adkins via samba
> > > Verzonden: dinsdag 4 december 2018 5:33
> > > Aan: samba@xxxxxxxxxxxxxxx
> > > Onderwerp: [Samba] Required to Build Samba
> > > 
> > > The wiki:
> > > https://wiki.samba.org/index.php/Package_Dependencies_Required
> > > _to_Build_Samba
> > > 
> > > Debian / Ubuntu
> > > 
> > > These 2 packages are not available for 18.04 but are for 16.04
> > > python-gpgme python3-gpgme
> > 
> > If you look here : 
> > 
> https://packages.ubuntu.com/search?suite=default&section=all&a
> rch=any&keywords=gpgme&searchon=sourcenames 
> > You see, 
> > bionic (libdevel): 1.10.0-1ubuntu1 
> > Binaire pakketten: libgpgme-dev, libgpgme11, libgpgmepp-dev,
> > libgpgmepp-doc, libgpgmepp6, libqgpgme7, python-gpg, python3-gpg
> > These replaces the gpme for 18.04
> > 
> > If you look into this file. 
> > 
> https://downloads.van-belle.nl/samba4/Buildlogs/ubuntu/samba_4
> .9.3+nmu-1.3~ubuntu1804_amd64.buildinfo 
> > You see Depends: and all the packages used in my builds. 
> > 
> > > 
> > > Does this mean you can't build on 18.04?  I assume so.
> > Yeah, you can build it on 18.04. 
> > If you use my repo its sources, and run apt-get build-dep samba 
> > You see all the needed build depends. 
> > 
> > > 
> > > I assume this is okay: Note, selecting 'perl-modules-5.26' 
> > > instead of 'perl-modules'
> > 
> > Yeah, i see, the wiki needs a bit of updating for the builds on
> > bionice. I'll see if i can make some time, and update it a bit.
> > 
> 
> Well, if you read the notes under the main list of required packages,
> there are these lines:
> 
> perl-modules has been replace by perl-modules-5.26 on Ubuntu Artful
> (17.10)
> python-gpgme and python3-gpgme have been replaced by python-gpg and
> python3-gpg on Debian Stretch and Ubuntu Artful 

Here we need to change Stretch to Debian 9 and up  
and Artful to Ubuntu 17.10 and up. 

I think thats a bit better to understand. 

> 
> If you can tell me why you didn't understand them or missed them, I
> will try to change them, but, until Ubuntu 14.04 finally goes  EOL (next
> year), the main block will have to stay as it is.

The mainblock is fine. 

> 
> Rowland
>  
> 
> 
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba
> 

Greetz, 

Louis


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba