Web lists-archives.com

Re: [Samba] Debian Stretch Samba 4.8.7 packages available amd64/i386




Hai Dennis, 

> -----Oorspronkelijk bericht-----
> Van: Denis Cardon [mailto:dcardon@xxxxxxxxxxx] 
> Verzonden: woensdag 28 november 2018 21:41
> Aan: samba@xxxxxxxxxxxxxxx; L.P.H. van Belle
> Onderwerp: Re: [Samba] Debian Stretch Samba 4.8.7 packages 
> available amd64/i386
> 
> G'day Louis,
> 
> > The Debian Stretch packages for samba 4.8.7 are now 
> available for amd64 and i386.
> 
> When I tried to rebuild debian stretch 4.8.7 packages using your repo 
> today, I came across an issue and it seems that your 
> stretch-samba48/main/source/Sources.gz is missing the 
> reference of cmoka 
> 1.1.1 entry (otherwise apt-get source downloads 1.0.1 version and the 
> build fails miserably). And actually the dsc and tar.xz are 
> there just waiting to be downloaded :-)

I'll have a quick look and ahhh.. I've seen whats going on here. 
The package is/was available, just not in the stretch-samba48 ( it was in the 4.7 ) 
The latest builds took the files from cache, so cleaned that up, wont happen again. 
I've updated the repo so you can use the files now. 
And.. p.s.  cmocka 1.1.1 is also in stretch-backports, that where i took this one from. 

> 
> By the way, looking at this cmocka issue, I was looking at 
> third-party stuff in the build, since cmocka is in itself not a Samba packages. 
> That may be a question more appropriate for samba dev, but I was wondering if 
> the third-party folder in samba tarball is safe to ignore and always take upstream?

This totaly depends on the build depends and whats done on samba.

What i do, so you can understand better how i get to my builds.
I follow samba-technical to keep track of whats done on samba and debian-samba and regulary check the debian samba package for fixes.
And use as much from the stable debian repo where possible. 

These first 2 are the most important, because latest upstream is not always what you need. 
For example, have a look at ldb:  https://ftp.samba.org/pub/ldb/?C=M;O=D
We see here 1.4.3 but also 1.5.1 and 1.3.6. 

And check what is needed ( minimal ) versions
grep ^VERSION lib/{talloc,tdb,tevent,ldb}/wscript
grep minversion buildtools/wafsamba/samba_third_party.py | awk -F"(" '{ print $2 }'
But read of there isnt also a "maximun" version.

Once i know the versions needed, im checking here the following.
The debian samba experimental/unstable packages, if these are there i use these where possible. 
And the git of https://salsa.debian.org/samba-team/samba 

And based on need, im getting the sources. 
This is the build order im using. 
talloc tevent tdb cmocka lmdb-jessie ldb nss-wrapper resolv-wrapper uid-wrapper socket-wrapper pam-wrapper samba

The "wrappers" are bit harder to find but found here : https://ftp.samba.org/pub/cwrap/?C=M;O=D 

Based on all above info, then i deside whats good for a stable build. 
Latest is not always best.

> 
> thanks a lot for your hard dedicated works.
> 
> Cheers,
> 
> Denis
> 

You welkom, and thank you for the notice on the missing source package. 


Greetz, 

Louis



-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba