Web lists-archives.com

[Samba] SOLVED [was re: Howto enable ldapi socket?]




Hi Rowland,

while checking the existence of ldapi socket, the samba server simply
did not run :-/. I was not aware, that samba has to run for creating
ldapi socket. Now all is fine.

Tfh!

Oliver


On 26.11.18 21:42, Oliver Rath via samba wrote:
> Hi Rowland!
>
> On 26.11.18 19:37, Rowland Penny via samba wrote:
>> [..]
>> adminuser@ubutestdc:~$ ls -la /var/lib/samba/private/ldapi
>> srwxrwxrwx 1 root root 0 Nov 25 17:13 /var/lib/samba/private/ldapi
> Also strange:
>
> # dpkg-query -l *samba*
> Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
> | Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/
>          Halb installiert/Trigger erWartet/Trigger anhängig
> |/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler:
> GROSS=schlecht)
> ||/ Name                            Version             
> Architektur          Beschreibung
> +++-===============================-====================-====================-====================================================================
> ii  python-samba                    2:4.9.2+nmu-1~ubuntu
> amd64                Python bindings for Samba
> un  python2.7-samba                 <keine>             
> <keine>              (keine Beschreibung vorhanden)
> ii  samba                           2:4.9.2+nmu-1~ubuntu
> amd64                SMB/CIFS file, print, and login server for Unix
> ii  samba-common                    2:4.9.2+nmu-1~ubuntu
> all                  common files used by both the Samba server and client
> ii  samba-common-bin                2:4.9.2+nmu-1~ubuntu
> amd64                Samba common files used by both the server and the
> client
> un  samba-dev                       <keine>             
> <keine>              (keine Beschreibung vorhanden)
> ii  samba-dsdb-modules:amd64        2:4.9.2+nmu-1~ubuntu
> amd64                Samba Directory Services Database
> ii  samba-libs:amd64                2:4.9.2+nmu-1~ubuntu
> amd64                Samba core libraries
> ii  samba-testsuite                 2:4.9.2+nmu-1~ubuntu
> amd64                test suite from Samba
> ii  samba-vfs-modules:amd64         2:4.9.2+nmu-1~ubuntu
> amd64                Samba Virtual FileSystem plugins
> rc  vlc-plugin-samba:amd64          3.0.3-1-1ubuntu1    
> amd64                Samba plugin for VLC
>
> BUT:
>
> # ls -l /var/lib/samba/private/ldapi
> ls: cannot access '/var/lib/samba/private/ldapi': No such file or directory
>
>> Having said that, why not use kerberos, it is more secure.
> Yes, you said :-). But Im testing Rust ldap3-lib, which only is able to
> use SASL and ldapi, not kerberos. Finding some rust lib able using
> kerberos, i will change.
>
> For my ldapi-problem, I make some further resarch and will report.
>
> Tfh!
>
> Oliver
>
>

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba