Web lists-archives.com

Re: [Samba] winbind service panics "randomly"




"Small" correction from previous mail:
bind9 and isc-dhcp-server are NOT installed on the file server. Only the
DC's.

sorry

Carlos Jesus <camjesus2@xxxxxxxxx> escreveu no dia quarta, 14/11/2018 à(s)
13:00:

> Hey Roland,
> Since my last e-mail, I went to sleep and left the thing running. It's a
> production server (from "9 to 5") and for the last hours it has been
> working flawlessly. I'm beginning to think it's not really "random". Not
> really sure it's a bug; it seems to happen when I check it with wbinfo (the
> log I sent was a good example). But not always. Weird.
>
> 1) Anyway, packages. This is basically what's on the wiki:
> acl attr autoconf bind9utils bison build-essential debhelper dnsutils
> docbook-xml docbook-xsl flex gdb libjansson-dev krb5-user  libacl1-dev
> libaio-dev libarchive-dev libattr1-dev libblkid-dev libbsd-dev libcap-dev
> libcups2-dev libgnutls28-dev libgpgme-dev libjson-perl  libldap2-dev
> libncurses5-dev libpam0g-dev libparse-yapp-perl  libpopt-dev
> libreadline-dev nettle-dev perl perl-modules.5-24 pkg-config
> python-all-dev python-crypto python-dbg python-dev python-dnspython
> python3-dnspython python-gpg python3-gpg python-markdown python3-markdown
> python3-dev xsltproc zlib1g-dev liblmdb-dev lmdb-utils libsystemd-dev
>
> 2) config line (common to the FS and DC's except for the -j option):
> ./configure -j8 -v --with-systemd
>
> This is a +/- standard debian installation, still (and this is probably
> useless info):
> lxde/lightdm instead of gnome; avahi, nfs, wicd disabled; network managers
> disabled; installed isc-dhcp-server, bind9, ntp, ethtool, iftop, iperf3,
> rsync, ifenslave, bridge-utils, pigz, htop, fortune, cowsay, x11vnc,
> openvpn
>
> I'm (remotely) keeping a close eye on the thing. I can only test stuff
> after office ours but I can monitor and will report here any findings.
> Again, thanks for the amazing work.
> Best regards
> Carlos
>
> Rowland Penny via samba <samba@xxxxxxxxxxxxxxx> escreveu no dia quarta,
> 14/11/2018 à(s) 08:43:
>
>> On Tue, 13 Nov 2018 23:35:46 +0000
>> Carlos Jesus <camjesus2@xxxxxxxxx> wrote:
>>
>> > Hi Rowland,
>> > thank you for another quick reply.
>> >
>> > 1) I did all the changes on the smb.conf you suggested and restart
>> > samba-ad-dc on both DCs.
>> > 2) Changed file server log to 10 and rebooted it just because.
>> > 3) Winbind crashed.
>> > 3.1) I have a gut felling that if I leave it alone, it lasts longer.
>> > If I do a wbinfo -u it's ok, but if I go and check it often, it
>> > eventually crashes. Again, gut felling, maybe it's just a bad dinner.
>> > I'll try to find a way to automate this.
>> > 4)  wbinfo --group-info="Domain Users"
>> > EUROHIDRA\domain users:x:10001:
>> > 5) Don't really know what to look for in the logs, but I can't see
>> > anything clearly wrong. Any tips for things to look for? Log 10 is,
>> > well, verbose... I think I didn't overlook anything obvious, but still
>> > 6) Here's the last seconds of the log before winbind panicked.
>> >
>>
>> Well, it shouldn't crash, so before we raise a bug report, give me the
>> following info and I will try to recreate it.
>>
>> What packages did you install to compile samba ?
>> what was your './configure' line
>>
>> Rowland
>>
>> --
>> To unsubscribe from this list go to the following URL and read the
>> instructions:  https://lists.samba.org/mailman/options/samba
>
>
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba