Web lists-archives.com

[Samba] FSMO sieze syntax not working




Hi,

I had a hardware failure this week on one of my DCs.. not a problem I
thought, I will restore from backup.. All good, but from it turns out
that the backup was fully up to date apart from my /usr/local/samba
folder, which was from 2016 (don't ask...! I am quite embarrassed
about that)

I did boot up the DC (DC1) before I realised.. but I have since
renamed the /usr/local/samba folder to /usr/local/samba.OLD, as I
clearly shouldn't have been running a 2016 version of samba with 2016
data files in my current domain. I then re-joined DC1 back to the
domain, this seemed to work OK.

However I don't think that my FSMO roles are correct at the moment,
they all refer to the old DC1. When joining the domain I got:

[lots of installation messages]
WARNING: Unable to replicate own RID Set, as server dc2.mydomain.org
(the server we joined) is not the RID Master.
[more installation messages]

A 'samba-tool fsmo show' before re-joining DC1 back to the domain
showed all roles as still running on DC1:
SchemaMasterRole owner: CN=NTDS
Settings,CN=DC1,CN=Servers,CN=MySite,CN=Sites,CN=Configuration,DC=mydomain,DC=org
[all other roles look the same]

Now that DC1 is joined back to the domain, they all look like this:
SchemaMasterRole owner: CN=NTDS
Settings\0ADEL:aaaaaaaa-bbbb-cccc-dddd-eeeeeeeeeeee,CN=DC1\0ADEL:ffffffff-1111-2222-3333-444444444444,CN=Servers,CN=MySite,CN=Sites,CN=Configuration,DC=mydomain,DC=org

which makes sense, as the old DC1 has been removed.


However - this is where I am having problems. I can't seem to sieze
the roles onto DC2 (which has been running for years and should still
be fine...)

Am I getting the syntax wrong?

I have been following the guide on the wiki:
https://wiki.samba.org/index.php/Transferring_and_Seizing_FSMO_Roles#Seizing_a_FSMO_Role

however when I run the following command, this is what happens:
dc2:~ $ sudo samba-tool fsmo sieze --role=rid
Usage: samba-tool fsmo <subcommand>
samba-tool fsmo: error: no such option: --role

I'm running samba 4.9, in case that makes a difference.
dc2:~ $ smbd -V
Version 4.9.0

and I'm fairly sure that the right version of samba-tool is being run,
i.e. there isn't an old binary left behind from a previous samba
version:
dc2:~ $ sudo which samba-tool
/usr/local/samba/bin/samba-tool


Any pointers would be appreciated...!

Cheers,

Jonathan

-- 
"If we knew what it was we were doing, it would not be called
research, would it?"
      - Albert Einstein

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba