Web lists-archives.com

Re: [Samba] Error running "samba-tool dbcheck" after going from 4.8.6 to 4.9.2




> I just tested Samba 4.9.2 on one of my DCs, previously running
> version 4.8.6. Immediately after install, I ran "samba-tool dbcheck"
> and got the following:
> 
> Checking 511 objects
> ERROR(<type 'exceptions.UnicodeDecodeError'>): uncaught exception - 
> 'ascii' codec can't decode byte 0xc3 in position 25: ordinal not in 
> range(128)
>    File 
> "/usr/local/samba/lib64/python2.7/site-packages/samba/netcmd/__init__.py", 
> line 177, in _run
>      return self.run(*args, **kwargs)
>    File 
> "/usr/local/samba/lib64/python2.7/site-packages/samba/netcmd/dbcheck.py", 
> line 157, in run
>      controls=controls, attrs=attrs)
>    File 
> "/usr/local/samba/lib64/python2.7/site-packages/samba/dbchecker.py", 
> line 222, in check_database
>      error_count += self.check_object(object.dn, attrs=attrs)
>    File 
> "/usr/local/samba/lib64/python2.7/site-packages/samba/dbchecker.py", 
> line 2315, in check_object
>      expected_dn = ldb.Dn(self.samdb, "RDN=RDN,%s" % (parent_dn))
> 
> 
> The error disappears after going back to Samba 4.8.6. The underlying
> OS is CentOS 7.4.
> 
> Although the names my users use at logon don't have accented
> characters, several of them have them in their complete names.
> Several of the group names also have accented characters.
> 
> This is likely the same error reported under Bug 13616, which
> meanwhile has been declared as closed.
> https://bugzilla.samba.org/show_bug.cgi?id=13616
> 

The bugfix seems applied to ldb version 1.4.3 so samba should recompile
against ldb-1.4.3 regardless any samba-4.9 version.


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba