Web lists-archives.com

Re: [Samba] Kodi crashes when trying to browse network




Hai, 


smbclient -L  $(hostname -s) on CLI, wworks witout problem on ubuntu 18.04,
with the newly builded samba 4.9.1 package from repo and the kodi 18 Beta4.

I also noticed that kodi 18 has some setting now in /home/kodi/.kodi/userdata/guisettings.xml 

    <setting id="smb.legacysecurity" default="true">false</setting>
    <setting id="smb.maxprotocol" default="true">3</setting>
    <setting id="smb.minprotocol" default="true">0</setting>
    <setting id="smb.winsserver" default="true">0.0.0.0</setting>

Its a headless server so in this case im unable to test from within kodi, atm. 
But Michael count try to to adjust the maxprotocol from within kodi and see if that helps. 

Greetz, 

Louis


> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens 
> L.P.H. van Belle via samba
> Verzonden: vrijdag 2 november 2018 9:36
> Aan: samba@xxxxxxxxxxxxxxx
> Onderwerp: Re: [Samba] Kodi crashes when trying to browse network
> 
> Hai Rowland,
> 
> > On Fri, 2 Nov 2018 08:33:56 +0100
> > "L.P.H. van Belle via samba" <samba@xxxxxxxxxxxxxxx> wrote:
> > 
> > > Hai, 
> > > 
> > > I think he also forgot to mention this part of kodi and smbclient.
> > > 
> > > ( the default of kodi its smbclient  ) 
> > > .smb/smb.conf
> > > [global]
> > >         lock directory = /home/username/.kodi/.smb/
> > >         name resolve order = bcast host
> > >         include = /home/username/.kodi/.smb/user.conf
> > > 
> > > I suggest, he needs to add the needed smbclient -mSMB1 into the
> > > user.conf of kodi. At least he should try it witout the 
> > bcast in name
> > > resolv oder. This looks a bit like the NMBD broadcast bug.
> > > 
> > > 
> > 
> > Ah, I think I understand this a bit better now. Kodi runs smbclient
> > from a GUI. Can you get to a CLI on Kodi ? If so, running smbclient
> > directly may give more info.
> > 
> > Rowland
> > 
> > -- 
> > To unsubscribe from this list go to the following URL and read the
> > instructions:  https://lists.samba.org/mailman/options/samba
> > 
> 
> 
> If you want, and give me some time.  
> I've just set up a ubuntu bionic repo for samba 4.9 which 
> fixes the depend problem with the Debian stretch version. 
> And im able to install kodi 18 also, i can then do a test 
> from cli but not from within kodi.
> For that i need to be home. ;-) 
> 
> Greetz, 
> 
> Louis
> 
> 
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba
> 
> 


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba