Web lists-archives.com

[Samba] Ready to test Samba 4.9.1. for Debian Stretch ( or ubuntu 18.04 or Devuan ASCII ) AMD64 only




Hai... 
 
Finaly im passed all errors, some problem with meself.. , some the code. ..  
 
Lots of thank to the samba devs, that gave the clue to fix the last parts. :-)) whoehoe.. 
 
Its still in the stretch-experimental repo, and if the feedback is ok, i'll make the final build tomorrow. 
Testing can be done with Debian Stretch or Ubuntu 18.04 amd64 or Devuan ASCII AMD64 only.
 

#setup: get my key:  
wget -O - http://apt.van-belle.nl/louis-van-belle.gpg-key.asc | apt-key add -
 
#setup apt. 
echo "deb http://apt.van-belle.nl/debian stretch-experimental main contrib non-free" | sudo tee -a /etc/apt/sources.list.d/van-belle.list
 
apt-get update 
apt-get install samba winbind
 
 
The changelog for this one, so you can see whats done already is below. 
One of the showstoppers was the last one the guest/idmap part. 
 
If you install new, you get the config with this part enabled by default. 
    idmap config * :              backend = tdb
    idmap config * :              range   = 3000-7999

If you upgrade and the default is still there and not changed, it will be enabled. 
 
Any other settting, you must change it yourself, or run:  
net groupmap add sid=S-1-5-32-546 unixgroup=nogroup type=builtin
 
 
The change log for 4.9.1 ( as of 4.9.0 ) 
samba (2:4.9.1+nmu-2.8) stretch; urgency=medium
 
  * Non-maintainer upload.
  * Rebuild from Debian samba (salsa git) to Stretch.
  * Add build depends pam_wrapper 1.0.7~ to allow build tests
  * Bump build depends cmocka 1.1.2
  * d/rules added systemd-*-extra options for the service files.
  * d/control added libtracker-..   to allow build with spotlight support
  * d/rules added --enable-spotlight
  * d/rules enabled/added --with-shared-modules vfs_nfs4acl_xattr
    - Do note, this is still experimental.
  * Added build depend liblmdb-dev to allow lmdb backends.
  * update lintian override for the unnecessary-activation-of-ldconfig triggers
  * d/samba-common.postinst added sed parts to enable idmap * by default.
    - only works when the idmap config * isn't changed to allow install/upgrades
      where smbd fails to start due to unresolved guest user.
 
 -- Louis van Belle <louis@xxxxxxxxxxxx>  Thu, 18 Oct 2018 15:42:57 +0000
 
samba (2:4.9.1+dfsg-2) UNRELEASED; urgency=medium
 
  * Enable --accel-aes=intelaesni on DEB_HOST_ARCH_CPU=amd64 instead of
    DEB_HOST_ARCH=amd64. This matches samba-libs.install and adds x32
  * Allow one to change password via passwd in default config
    - third_party: Update pam_wrapper to version 1.0.7
    - third_party: Add pam_set_items.so from pam_wrapper
    - nsswitch: Add try_authtok option to pam_winbind
    - tests: Check pam_winbind pw change with different options
    - Patch for previous 4 commits
    - debian/winbind.pam-config: Use the new try_authtok option allowing
      password change while preserving current behavior with password strength
      modules (Closes: #858923, LP: #570944)
  * README.source: use gbp pull --track-missing
  * Override library-not-linked-against-libc false positives (See #896012)
  * Fix wrong-path-for-interpreter for pidl and findsmb
  * ctdb.postrm: Fix to disable_legacy (found by piuparts)
 
 -- Mathieu Parent <sathieu@xxxxxxxxxx>  Tue, 09 Oct 2018 10:09:09 +0200
 
samba (2:4.9.1+dfsg-1) experimental; urgency=medium
 
  * New upstream release
 
 -- Mathieu Parent <sathieu@xxxxxxxxxx>  Mon, 24 Sep 2018 13:33:21 +0200
 
samba (2:4.9.0+dfsg-1) experimental; urgency=medium
 
  * Upload to experimental
  * New upstream release
    - Update d/gbp.conf, d/watch and d/README.source for 4.9
    - Remove Fix-pidl-manpage-sections.patch, Fix-spelling.patch and
      Improve-vfs_linux_xfs_sgid-manpage.patch, merged upstream
    - Bump build-depends talloc >= 2.1.14, tdb >= 1.3.16, tevent >= 0.9.37 and
      ldb >= 2:1.4.2'
    - Update paths
    - Update libsmbclient.symbols
    - ctdb.lintian-override: Remove script-not-executable override
    - Add ctdb.NEWS: "Configuration has been completely overhauled"
    - ctdb: Enable/disable legacy script in postinst/presinst

 -- Mathieu Parent <sathieu@xxxxxxxxxx>  Sat, 22 Sep 2018 23:04:11 +0200

 


 
Good luck, 
I'll read any feedback/questions tomorrow morning.
 
Greetz, 
 
Louis
 
 

 
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba