Web lists-archives.com

Re: [Samba] Upgrade 4.8 to 4.9 with Backend-Change to lmdb?




Yes, 

Ive fixed 1 of the 2 problems at install. 
Im testing fix 2 atm, and ask @technical for extra info. 

There are 2 bugs with the upgrade of 4.8 to 4.9.
For others, please note, i've only tested this on debian with the debian packages (experimental) and my own packages. 
Bug 1) at install samba is unable to start due to : 
	a change (commit) 0b261dc4e3f2 in 4.9 that requires to have BUILTIN\Guests group always to be mapped
	here there are 2 fixed, as suggested by Alexander
	fix 1) 
	net groupmap add sid=S-1-5-32-546 unixgroup=nobody type=builtin  << on debian dont use that. 
	use : net groupmap add sid=S-1-5-32-546 unixgroup=nogroup type=builtin
	( change nobody to nogoup) 

	fix 2)
	change smb.conf and enable idmap * 
	This is the fix i implemented in the package, mainly because now you see thats done. 
	fix 1, can be forgotten in time and might kick back later on.. 

Bug 2) when you install (apt install samba winbind)  then both smbd and winbind wont start due to 
	extra added parts in the systemd files and these are copied to /etc/systemd/system 
	This is a debian policy confict and this should not happen. 
	The correct and working files exact at /lib/systemd/system  

So after getting passed bug1 i did hit bug2.  :-( 
	you can get easy past it by removing the files in /etc/systemd/system smbd/winbind/samba/nmbd service files
	run : systemctl daemon-reload 
	run : apt-get -f install 
	
	then the install continues. 

You only see this with a new install, because these are set to "standalone server".
Once set to ad-dc or member server, you dont see bug 1, you only might hit bug2. 

So you can test the 4.9.1 packages, but only when im 10000000% sure the package install and upgrades are ok.
Only then, I'll put them in the 4.9 repo, for now they are still in the stretch-experimental repo. 
Im updating these lots atm to test packages out. 
I ( and all the people using these packages ) cant have a failty upgrade or stalled install. 

Conclusion, for production, no not yet, for testing yes please. 
I have some report back already that once you got past the 2 bug samba runs fine. 


Greetz, 

Louis


> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens 
> Stefan G. Weichinger via samba
> Verzonden: woensdag 17 oktober 2018 11:25
> Aan: samba@xxxxxxxxxxxxxxx
> Onderwerp: Re: [Samba] Upgrade 4.8 to 4.9 with Backend-Change to lmdb?
> 
> Am 26.09.18 um 14:47 schrieb L.P.H. van Belle via samba:
> > Hai,
> > 
> > At this point i can not recommend to upgrade to 4.9.0 or 4.9.1, a
> > side note on this. The bug in question why im blocking it for
> > production, does not happen for domain members and AD-DC's but it's
> > still a risk in my opinion.
> 
> Is that still true (oct 17th 2018)?
> 
> Is that mentioned backend change obligatory?
> 
> Couldn't follow all the threads lately ;-)  ... but checking in to 
> prepare for upgrades over the next weeks or so.
> 
> Thanks, Stefan
> 
> 
> 
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba
> 
> 


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba