Web lists-archives.com

Re: [Samba] Domain Administrator and shares problems




Hi Louis,

I will give it a try when I'm back home in the evening.

Thanks!

Peter

On 10/10/18 11:18 AM, L.P.H. van Belle via samba wrote:
I suggest to the op check my settings and try it.
Should work.
Not showing the security tab is often an wrong right in the underlaying folder.

So in case of this one, i would check this first.
ls -al /data/
ls -al /data/samba
ls -al /data/samba/profiles

chmod 775 /data/  ! In case of a chmod 770 or 750 make sure you have a group set that is known in windows.
Same for /data/samba

chmod 1777 for /data/samba/profiles
Then when createing/settings the profiles in windows tools, first set the UNIX UID, klik apply.
Now set the profiles path, it should result in

# file: home/samba/profiles/username.V6
# owner: username
# group: domain\040users
user::rwx
user:username:rwx
group::---
group:2005:rwx
group:domain\040users:---
mask::rwx
other::---
default:user::rwx
default:user:obell:rwx
default:group::---
default:group:2005:rwx
default:group:domain\040users:---
default:mask::rwx
default:other::---

Do note the UID 2005, that is the one that created the folder. ( user : SYSTEM )

Greetz,

Louis



The problem isn't whether 'Domain Admins' has a gid or not, the OP
cannot open the security tab on windows as Administrator.

This is something I can only reproduce by not having a user.map in
smb.conf

Rowland

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba




--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba