Web lists-archives.com

Re: [Samba] Can't access samba because "session setup failed: NT_STATUS_INVALID_SID"




On Sun, 30 Sep 2018 16:32:38 +0000
Junior Oliveira via samba <samba@xxxxxxxxxxxxxxx> wrote:

>  I have an instance of samba 4 where users gonna authenticate on it
> through a OpenLDAP server. The user from LDAP are already configured
> with samba credentials. The issue is that they are set with an SID
> different from the one of my machine with samba 4, i guess it's
> because there was an old samba 3 in use when these users were
> created. When i create a new user with "smbldap-tools", it logs in
> the samba correctly, but the old users don't. Anyways, all the users
> either old or new need to use this samba 4 now. Should i change the
> SID of my samba instance to the old set on the old users in order to
> settle this problem? What would be the best solution for this?
> 
> Thanks in advance.

I would suggest you stop using old outdated ways of doing things ;-)

As far as I can see 'smbldap-tools' is dead, there doesn't seem to be a
home webpage anywhere and as such it is now unmaintained. It only
needs a perl update to break it.

We now move to Windows, Microsoft seems to be trying to stop NT4-style
domains working, this may be by accident, or on purpose, but it is
happening.

Can I suggest you upgrade to a Samba AD domain, it is easier to
maintain and works with current (and past) versions of Windows.

Rowland

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba