Web lists-archives.com

Re: [Samba] IOS connections to Samba 4 worked for years, now authentication fails




Am Freitag, 28. September 2018, 21:38:07 CEST schrieb Deft Developer via 
samba:
> We have samba 4.8 and 4.9 servers that are Active Directory members.
> Windows and other samba clients can access the shares, and for years,
> iOS devices worked fine with Samba 4. But a few months ago, Apple IOS
> 10 and 11 devices started failing to authenticate. The problem is
> common to several iOS apps, FileBrowser, SMBManager, and some 
others
> all fail. The App vendors are stonewalling us, and giving stupid
> advice like restarting the devices.
> 
> 
> 
> The logs on the Samba servers say FAILED with error
> NT_STATUS_LOGON_FAILURE, regardless of what type of
> username+password, with or without the domain name.
> 
> 
> 
> The problem is only between iOS and Samba. These same iOS clients can
> connect to Windows 7 and Windows server 2008 shares, and Windows 
and
> Samba clients can access the shares as expected.
May be, your samba servers have the smb1 protocol disabled now.

Reenable the smb1 protocol on your samba servers and you will get back 
network neighborhood. All your apps which depends on smb version 1 will 
work again, at the risk that your network is insecure.

If that is the case you should do something soon.

Today one should use "network discovery" for domain browsing or 
something else like avahi or ...

> What happened, and is there a way around this issue?


-- 

Gruss
	Harry Jede
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba