Web lists-archives.com

Re: [Samba] Upgrade 4.8 to 4.9 with Backend-Change to lmdb?




On Thu, 27 Sep 2018 10:12:56 +0200
Denis Cardon <dcardon@xxxxxxxxxxx> wrote:

> Hi Rowland,
> 
> >>> - Option 1: ( my personal choice, because this keeps thing in
> >>> sight )
> >>> - ( Domain Member settings and/or Stand-Alone installs )
> >>> - Configure smb.conf  ( make sure you have configured the idmap
> >>> settings. ) # - You must set a DOMAIN backend configuration, see
> >>> below idmap config * : backend = tdb
> >>>        idmap config * : range = 3000-7999
> >>>
> >>> - Domain Member only setting, choose one of these 2, read and
> >>> choose. https://wiki.samba.org/index.php/Idmap_config_ad
> >>> https://wiki.samba.org/index.php/Idmap_config_rid
> >>
> >> I have always been configuring a tdb backend for builtin users
> >> aside from the rfc2307 or rid backend for domain users (like in
> >> [1]). In which documentation is it missing this piece of
> >> information?
> >
> > I will turn that on its head ;-)
> 
> do as you please as long as it is constructive. :-)
> 
> > If you read 'man idmap_tdb', you will find this:
> >
> >  [global]
> >  # "backend = tdb" is redundant here since it is the default
> >  idmap config * : backend = tdb
> >  idmap config * : range = 1000000-2000000
> >
> > Which means that you do not have to add the 'backend' line.
> 
> one more line for more clarity is not a hefty price to pay. One of
> the objective of a tutorial is to help the reader understand what he
> does!

Not saying you shouldn't add it and like you, I always add it if
required, but what I was trying to point out to Louis is, you don't
need to add it to a standalone server, it is already there, even if you
cannot see it ;-)

The problem that Louis has with installing samba, doesn't have anything
to do with those lines. It is that smbd will not run on a standalone
server if winbind is already running, stop winbind, make no changes
(i.e. don't add the lines Louis suggest) and smbd will start without
error.

> 
> >>
> >> Cheers,
> >>
> >> Denis
> >>
> >> [1]
> >> https://dev.tranquil.it/wiki/SAMBA_-_Installation_d%27un_nouveau_serveur_de_fichiers_Samba4#Configuration_smb.conf
> >
> > Your wiki page needs updating, all supported Samba versions now use
> > a slightly different 'ad' setup and I wish I knew who thought it
> > was good idea to recommend putting the '*' domain above the
> > 'DOMAIN' domain.
> 
> Well, sorry to disappoint you but that wiki configuration does work
> with current Samba version. And it does not matter to have the
> "catchall" idmap configuration above or under the domain idmap
> configuration.

I was referring to the 'ad' lines and I refer you to my earlier
response to one of Louis's posts, in my opinion, it is a bad idea to
put the '*' domain above the 'DOMAIN' domain. However, it is your wiki
and you can do as you like.

> 
> Cheers,
> 
> Denis
> 
> PS : by the way I am wondering what fantastic job you have that
> allows you to spend so much time on the mailing list :-) ? I'm sure
> doing Samba mailing list posting all day long does not "put butter in
> the spinach" (like we frogs say here) !

Try being classified as disabled due to two damaged vertebrae and not
being able to move around a lot.

Rowland



-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba