Web lists-archives.com

[Samba] Error from "samba-tool dbcheck" after upgrading 4.8.5 to 4.9.0




I just upgraded one of my DCs from 4.8.5 to 4.9.0. Immediately after
install, I ran "samba-tool dbcheck" and got the following:


Checking 511 objects
ERROR(<type 'exceptions.UnicodeEncodeError'>): uncaught exception - 'ascii'
codec can't encode character u'\xe1' in position 133: ordinal not in
range(128)
  File
"/usr/local/samba/lib64/python2.7/site-packages/samba/netcmd/__init__.py",
line 177, in _run
    return self.run(*args, **kwargs)
  File
"/usr/local/samba/lib64/python2.7/site-packages/samba/netcmd/dbcheck.py",
line 157, in run
    controls=controls, attrs=attrs)
  File "/usr/local/samba/lib64/python2.7/site-packages/samba/dbchecker.py",
line 221, in check_database
    error_count += self.check_object(object.dn, attrs=attrs)
  File "/usr/local/samba/lib64/python2.7/site-packages/samba/dbchecker.py",
line 2230, in check_object
    error_count += self.check_dn(obj, attrname, syntax_oid)
  File "/usr/local/samba/lib64/python2.7/site-packages/samba/dbchecker.py",
line 1182, in check_dn
    dsdb_dn = dsdb_Dn(self.samdb, val.decode('utf8'), syntax_oid)
  File "/usr/local/samba/lib64/python2.7/site-packages/samba/common.py",
line 101, in __init__
    self.dn = ldb.Dn(samdb, self.dnstring)


After going back to Samba 4.8.5 the error disapears.

The underlying OS is CentOS 7.4.



-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba