Web lists-archives.com

[Samba] lmdb requirement for AD DC




On Thu, 2018-09-13 at 14:41 +0100, miguel medalha via samba wrote:
> Hello
> 
> In one of my DCs, when I run ./configure for Samba 4.9.0, it fails
> with the following message:
> 
> Checking for lmdb >= 0.9.16 via header check		: not
> found
> Samba AD DC and --enable-selftest requires lmdb 0.9.16 or later
> 
> My ./configure command line does not contain the option "–enable-
> selftest", and "../configure –help" gives the following output:
> 
> --enable-selftest
>             enable options necessary for selftest (default=no)
> 
> If the default is "no" why is it behaving as if the option is
> enabled?
> 
> Am I doing something wrong?

No, sadly the configure check, exceptions and messages got a little
confused.  Please file a bug and we will fix it up, either to correctly
say it is required for the AD DC, or required for sefltest and the AD
DC.

For a number of reasons we do expect to be moving to LMDB, quite
possibly as the default, so expect this to get stronger in future major
versions. 

Andrew Bartlett

-- 
Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba




-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba