Web lists-archives.com

Re: [Samba] Samba4 creating users




Hello,

Thanks for your reply. I've included my smb.conf file below. I put a
few in-laid questions in it with # signs they are not on the server
just this file. If the file is missing anything let me know.

Thanks.
Dave.

smb.conf:
[global]
   workgroup = example
netbios name = example2
   wins support = yes
   dns proxy = no
# br0 is a bridge bridging ethernet eth0 and wlan0 it's the interface
with the IP
   interfaces = 127.0.0.0/8 br0
   bind interfaces only = yes
   log file = /var/log/samba/log.%m
   max log size = 1000
   server role = standalone server
   passdb backend = tdbsam
# Does enabling obey pam restrictions invalidate unix password sync,
passwd program, and passwd chat?
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n
*Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = no
   map to guest = Never
   usershare allow guests = no
security = user

[nas]
comment = Nas Storage
path = /media/disk1/downloads
valid users = @users
force group = users
create mask = 0660
directory mask = 0771
read only = no

[share-pc1]
comment = Pc1 Backup Files
path = /media/disk1/idea-pc
valid users = @users
invalid users = user1
force group = users
create mask = 0660
directory mask = 0771
read only = no

[share-pc2]
comment = Pc2 Backup Files
path = /media/disk1/kraken
valid users = @users
invalid users = user2
force group = users
create mask = 0660
directory mask = 0771
read only = no


On 9/4/18, Rowland Penny via samba <samba@xxxxxxxxxxxxxxx> wrote:
> On Mon, 3 Sep 2018 20:32:09 -0400
> David Mehler <dave.mehler@xxxxxxxxx> wrote:
>
>> Hello Rowland,
>>
>> Thanks for the pointer. The good news is I have it working.
>>
>> The bad news is there appears to be a problem. Both machines are on
>> the same subnet. I tried to connect from the win10 1803 box to the nas
>> box which has the netbios name of example2. It took almost a minute
>> before I was prompted for login credentials. Is this normal? Is there
>> anything I can do about it?
>>
>
> No, it's not normal, can you please post the smb.conf from the rpi.
>
> Rowland
>
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba
>

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba