Web lists-archives.com

Re: [Samba] Can not build Samba 4.7.10




Ok, the build finished successfull. 

I used this for the debian builds, so check what your missing. 
You need to change/skip some debian packages, maybe it helps finding whats going on. 
I dont know much about centos. (sorry) 

Build-Depends: bison,
               debhelper (>= 10),
               dh-exec,
               dh-python,
               docbook-xml,
               docbook-xsl,
               flex,
               glusterfs-common [linux-any],
               libacl1-dev,
               libarchive-dev,
               libattr1-dev,
               libavahi-client-dev,
               libavahi-common-dev,
               libblkid-dev,
               libbsd-dev,
               libcap-dev [linux-any],
               libcephfs-dev [linux-any],
               libcmocka-dev (>= 1.1.1~),
               libcups2-dev,
               libdbus-1-dev,
               libgnutls28-dev,
               libgpgme11-dev,
               libjansson-dev,
               libldap2-dev,
               libldb-dev (>= 2:1.2.3~),
               libncurses5-dev,
               libpam0g-dev,
               libparse-yapp-perl,
               libpcap-dev [hurd-i386 kfreebsd-any],
               libpopt-dev,
               libreadline-dev,
               libsystemd-dev [linux-any],
               libtalloc-dev (>= 2.1.14~),
               libtdb-dev (>= 1.3.16~),
               libtevent-dev (>= 0.9.37~),
               perl,
               pkg-config,
               po-debconf,
               python-all-dev (>= 2.6.6-3),
               python-dnspython,
               python-ldb (>= 2:1.2.3~),
               python-ldb-dev (>= 2:1.2.3~),
               python-talloc-dev (>= 2.1.14~),
               python-tdb (>= 1.3.16~),
               python-testtools,
               python3,
               xfslibs-dev [linux-any],
               xsltproc,
               zlib1g-dev (>= 1:1.2.3)
 
Greetz, 

Louis

Ps. Sorry 4.7.10 for the public wil be build next week. ;-)


> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens 
> L.P.H. van Belle via samba
> Verzonden: donderdag 30 augustus 2018 15:56
> Aan: samba@xxxxxxxxxxxxxxx
> Onderwerp: Re: [Samba] Can not build Samba 4.7.10
> 
> Hai, 
> 
> Hm, strange, i did a quick and dirty setup for a build of a 
> 4.7.10 based on my 4.7.9 package. 
> Its building atm, worked in the first go, but this is on debian. 
> 
> If you enter the source folder and run:
> grep ^VERSION lib/{talloc,tdb,tevent,ldb}/wscript
> grep minversion buildtools/wafsamba/samba_third_party.py | 
> awk -F"(" '{ print $2 }'
> 
> All requerements are installed? 
> 
> 
> Greetz, 
> 
> Louis
> 
> 
> > -----Oorspronkelijk bericht-----
> > Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens 
> > Thomas Nintemann via samba
> > Verzonden: donderdag 30 augustus 2018 15:34
> > Aan: samba@xxxxxxxxxxxxxxx
> > Onderwerp: Re: [Samba] Can not build Samba 4.7.10
> > 
> > 
> > Allready installed and it works absolut fine with Samba 4.7.9
> > 
> > Thomas
> > 
> > 
> > Zitat von "L.P.H. van Belle via samba" <samba@xxxxxxxxxxxxxxx>:
> > 
> > > If from source.
> > > https://ftp.samba.org/pub/ldb/ldb-1.2.3.tar.gz
> > >
> > > If its debian/ubuntu.
> > > Then you can get a ready source here.
> > > echo "deb-src http://apt.van-belle.nl/debian 
> stretch-samba47 main  
> > > contrib non-free" | sudo tee -a 
> > /etc/apt/sources.list.d/van-belle.list
> > > If you use jessie , change stretch-samba47 to jessie-samba47
> > >
> > > But my guess is the Op uses OpenSuse then its this link.
> > > 
> > http://rpm.pbone.net/index.php3/stat/4/idpl/44264775/dir/opens
> > use/com/ldb-tools-1.2.3-lp150.1.3.x86_64.rpm.html
> > >
> > >
> > > Greetz,
> > >
> > > Louis
> > >
> > >> -----Oorspronkelijk bericht-----
> > >> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens
> > >> Rowland Penny via samba
> > >> Verzonden: donderdag 30 augustus 2018 14:15
> > >> Aan: samba@xxxxxxxxxxxxxxx
> > >> Onderwerp: Re: [Samba] Can not build Samba 4.7.10
> > >>
> > >> On Thu, 30 Aug 2018 14:04:52 +0200
> > >> Thomas Nintemann via samba <samba@xxxxxxxxxxxxxxx> wrote:
> > >>
> > >> > Samba 4.7.10 is unwilling to find my pyldb-util v 1.2.3
> > >> >
> > >> > Checking for system pyldb-util (>=1.2.3
> > >> > <=1.2.999) : not found
> > >> > ERROR: System library pyldb-util of version 1.2.3 not 
> found, and
> > >> > bundling disabled
> > >> >
> > >> > Building of Samba 4.7.9 in the same environment works 
> flawlessly.
> > >> > What goes wrong in Samba 4.7.10 with detection of pylab?
> > >> >
> > >>
> > >> Does this happen if you try to build the latest version 
> of Samba ?
> > >> Never understood why people don't build the latest 
> > version, but build
> > >> an earlier version instead.
> > >>
> > >> What OS ?
> > >> What packages have you installed to build Samba ?
> > >>
> > >> Rowland
> > >>
> > >>
> > >> --
> > >> To unsubscribe from this list go to the following URL 
> and read the
> > >> instructions:  https://lists.samba.org/mailman/options/samba
> > >>
> > >>
> > 
> > 
> > 
> > -- 
> > --------------------
> > Medial-Networks
> > Thomas Nintemann
> > Landsbergstraße 45
> > 26871 Papenburg
> > Phone:+494961916744
> > Fax: +494961669546
> > USt-Id: DE205220654
> > ---------------------
> > 
> > 
> > -- 
> > To unsubscribe from this list go to the following URL and read the
> > instructions:  https://lists.samba.org/mailman/options/samba
> > 
> > 
> 
> 
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba
> 
> 


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba