Web lists-archives.com

Re: [Samba] Samba fileserver member corrupt smb.ldb after joining 4.8.4 Samba DC




On Sat, 25 Aug 2018 09:38:09 +0200
Waishon <waishon009@xxxxxxxxx> wrote:

> Hi,
> 
> that's interesting. Why does my other system returns S-1-22-1-0 with
> the Samba Database that was provisioned before 4.8.x and only
> upgraded. Mhh

Probably because you are using the 'rid' backend and I use the 'ad'
backend on Unix domain members.

> 
> The user.map contains:
> !root = SCHULE\\Administrator

It should be '!root = SCHULE\Administrator'

> 
> Have you tested the following:
> When running "samba ntacl get -D 10" onto a file with the permissions
> chown root:root, chmod 777, I get the stacktrace with the error in
> the above debug logs:
> uid_to_sid: winbind failed to find a sid for uid 0
> 
> When checking the same command against another file with the
> permissions chown "SAMDOM\\Administrator":"SAMDOM\\Administrator",
> chmod 777 I get the expected ntacl output without any crash.
> 
> Maybe you can check if you're able to reproduce this to know if it's a
> general bug or only a misconfiguration on my system.

I tried it on a Unix domain member and it didn't error, but I also
didn't get any output.

As Andrew said, there is a bug in there somewhere, it shouldn't panic,
but using samba-tool on a Unix domain member isn't really supported.
Some of it will work, but usually only when pointed at a DC.

Rowland
 

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba