Web lists-archives.com

[Samba] Typo + Stretch/Bionic packages [was Debian Jessie Samba packages 4.6.16/4.7.9/4.8.4 (amd64/i386) available]




Hi Louis,

I think, there is a typo in the samba48-repo:

samba 4.8.  :   echo "deb http://apt.van-belle.nl/debian jessie-samba47 ...

should be

samba 4.8.  :   echo "deb http://apt.van-belle.nl/debian jessie-samba48 ...

Do I see right, that there is no stretch/bionic packages for samba-4.8.4 at the moment?

Regards,
Oliver


On 21.08.2018 15:35, L.P.H. van Belle via samba wrote:
> Hai, 
>  
> Sorry for all delays, it was needed.
>
> I have also restructured the repo setup a bit, so package re-use is better which saved me some time. 
> This resulted in a samba 4.8 for jessie, no need for multiple repo lines anymore. 
> You choose the samba you want to run and you stay at that version until you change the repo. 
>  
> The site info isnt updated yet with this, i'll do that after i finish up with the debian stretch packages. 
> For now the Debian Jessie packages and available are amd64/i386 and sources. 
>  
> Import my key:  wget -O - http://apt.van-belle.nl/louis-van-belle.gpg-key.asc | apt-key add - 
>
> samba 4.5.x unmaintained/EOL  4.5.16 is the last.
>
> samba 4.6.  :   echo "deb http://apt.van-belle.nl/debian jessie-samba46 main contrib non-free" | sudo tee -a /etc/apt/sources.list.d/van-belle.list
> package list: http://apt.van-belle.nl/current-packages-in-jessie-samba46-apt.txt 
>  
> samba 4.7.  :   echo "deb http://apt.van-belle.nl/debian jessie-samba47 main contrib non-free" | sudo tee -a /etc/apt/sources.list.d/van-belle.list
> package list: http://apt.van-belle.nl/current-packages-in-jessie-samba47-apt.txt 
>  
> samba 4.8.  :   echo "deb http://apt.van-belle.nl/debian jessie-samba47 main contrib non-free" | sudo tee -a /etc/apt/sources.list.d/van-belle.list
> package list: http://apt.van-belle.nl/current-packages-in-jessie-samba48-apt.txt 
>  
> Build logs and .changes can be found here: 
> http://downloads.van-belle.nl/samba4/Buildlogs/jessie/ 
>  
> If extra packages are needed for the install, you need to use dist-upgrade of use apt-get install (packages list) 
>  
> If upgrade from a 4.5/4.6 to higher, i do advice to read : 
> http://downloads.van-belle.nl/samba4/Upgrade-info.txt 
>  
>  
> PLEASE NOTE! 
> THE OLDER REPO NAMES WONT GET THE UPDATE, YOU MUCH CHANGE THIS ONE TIME. (sorry for that)
>  
> The debian stretch line is going to follow the same structure. ( do note, not done yet, working on that now ) 
> This gives you the following advantage: 
> - You run Debian Jessie with samba 4.6, you want to upgrade debian to stretch but not samba. 
>    Change the repo line to stretch-samba46 and now your done. 
> - You run Debian Jessie with samba 4.6 and you want Debian Stretch with samba 4.8
>    Change the repo in jessie to jessie-samba48, upgrade samba, fix the smb.conf, change the repo to stretch-samba48
>     upgrade debian to stretch. 
>  
> And this might avoid problems while upgrading to os. 
> At least this works great for me. 
>
> If you find tips, problem etc, post it to the samba list, im there. 
> Happy Samba-ing...  
>
>
> Greetz,  
>  
> Louis 
>
>


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba